Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004889 [JEDI VCL] 00 JVCL Components major always 2009-08-09 12:17 2009-10-25 15:09
Reporter tetardd View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004889: Problem with displaying selected node in TJvTreeView
Description When a node is moved in TJvTreeView, the display as a selected node (background colour) is lost, even if HideSelection is False.
Additional Information See the example (executable and source) comparing the behaviour of TJvRichEdit (top) and VCL's TTreeView (bottom). Both have the same HideSelection = False.

Simply select a node (BBB, CCC, DDD), it will appear with the background colour of a selected node. Then click the button. The node is moved to the first position. In the case of TJvRichEdit, the selection colour is lost.
Do the same with TTreeView (bottom) and the selection colour is kept.
Tags No tags attached.
Attached Files zip file icon Bug ShowSelection TJvTreeView.zip [^] (391,652 bytes) 2009-08-09 12:17

- Relationships

-  Notes
(0016810)
AHUser (developer)
2009-10-25 15:09

Seems to be fixed with the fix for Mantis 0004994.

- Issue History
Date Modified Username Field Change
2009-08-09 12:17 tetardd New Issue
2009-08-09 12:17 tetardd File Added: Bug ShowSelection TJvTreeView.zip
2009-09-09 19:33 obones Status new => acknowledged
2009-10-25 15:09 AHUser Note Added: 0016810
2009-10-25 15:09 AHUser Status acknowledged => resolved
2009-10-25 15:09 AHUser Fixed in Version => Daily / SVN
2009-10-25 15:09 AHUser Resolution open => fixed
2009-10-25 15:09 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker