Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004897 [JEDI VCL] 00 JVCL Components major always 2009-08-13 14:26 2009-08-23 13:56
Reporter R2D2-Master View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.37
Summary 0004897: JvCSVDataset problem with comma inside string
Description This worked with previous versions of jvcl.

When there are a Comma inside a quoted string it breaks up the string into another column.

I have included a example code with csv file.

Thanks
Additional Information I am using Delphi 2007 on Windows XP
Tags No tags attached.
Attached Files zip file icon Example csvdataset comma problem.zip [^] (559,586 bytes) 2009-08-13 14:26

- Relationships
duplicate of 0004900resolvedAHUser TJvCsvDataSet, when loading, does'nt parse correctly text that contains a comma 

-  Notes
(0016010)
AHUser (developer)
2009-08-23 13:56

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2009-08-13 14:26 R2D2-Master New Issue
2009-08-13 14:26 R2D2-Master File Added: Example csvdataset comma problem.zip
2009-08-23 13:56 AHUser Relationship added duplicate of 0004900
2009-08-23 13:56 AHUser Note Added: 0016010
2009-08-23 13:56 AHUser Status new => resolved
2009-08-23 13:56 AHUser Fixed in Version => Daily / SVN
2009-08-23 13:56 AHUser Resolution open => fixed
2009-08-23 13:56 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker