Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004899 [JEDI VCL] 00 JVCL Components major always 2009-08-17 10:51 2009-10-03 15:52
Reporter freejay View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.37
Summary 0004899: TJvRichEdit content is not shown when placed on TAdvOfficePager (from TMS-Software)
Description If you put an TJvRichEdit component into the page of an TAdvOfficePager the content of the RichEdit (text, pictures etc) is not visible.

If I use the Delphi built-in TRichEdit instead the content is visible (it can not display pictures of course).
Additional Information If the TJvRichEdit component is placed anywhere else (outside the TAdvOfficePager) the content is displayed properly.

I didn't copile this project for a very long time so I don't know if this behaviour startet with Delphi 2009 or the latest JEDI version or the latest TMS Component Pack version, so I don't know if this problem is related to the JvRichEdit component or the AdvOfficePager.

I'm using JVCL V3.37 and TAdvOfficePager V1.7.1.4
Tags No tags attached.
Attached Files jpg file icon cropim10.jpg [^] (86,695 bytes) 2009-09-08 21:04

- Relationships

-  Notes
(0016060)
okaryn (reporter)
2009-09-08 21:06

Confirm with Delphi 2010, JVCL 1.38 and TMS Component Pack 5.2.4.1

The problem is with all TMS containers (AdvPanel, AdvPanelGroup, AdvPageControl, etc...)
(0016074)
obones (administrator)
2009-09-09 19:40

Well, we don't have the TMS components here, so we can't test.
And it seems to me it's an issue on their side with something they do to their containers.
Unless someone comes up with a solution, this will stay as is.
(0016077)
okaryn (reporter)
2009-09-09 19:49

Thanks,

The TMS answer (on their newsgroup) :

--
"I can only suspect this issue is in TJVRichEdit,
it does not happen with a regular TRichEdit."
--

Because TJVRichEdit is the only component with this problem (VCL TRichEdit work fine) ? I will waiting for new answer from their support. Wait & see...
(0016230)
AHUser (developer)
2009-10-03 15:30

> I can only suspect this issue is in TJVRichEdit,

My research shows that if I place a non-VCL control (CreateWindowEx) between the TAdvOfficePage and the TJvRichEdit the content is visible again. This implies that TAdvOfficePage does something with its child VCL controls. But without the TAdvOfficePage source code it is only guess work.
(0016231)
AHUser (developer)
2009-10-03 15:52

Fixed in SVN.

The new Delphi 2009 ParentDoubleBuffered property was not set to False. And because TAdvOfficePage uses double buffering the new property propagated the double buffering into every child including JvRichEdit which doesn't work with enabled double buffering.

- Issue History
Date Modified Username Field Change
2009-08-17 10:51 freejay New Issue
2009-09-08 21:04 okaryn File Added: cropim10.jpg
2009-09-08 21:06 okaryn Note Added: 0016060
2009-09-09 19:40 obones Note Added: 0016074
2009-09-09 19:40 obones Status new => feedback
2009-09-09 19:49 okaryn Note Added: 0016077
2009-10-03 15:30 AHUser Note Added: 0016230
2009-10-03 15:31 AHUser Assigned To => AHUser
2009-10-03 15:31 AHUser Status feedback => assigned
2009-10-03 15:52 AHUser Note Added: 0016231
2009-10-03 15:52 AHUser Status assigned => resolved
2009-10-03 15:52 AHUser Fixed in Version => Daily / SVN
2009-10-03 15:52 AHUser Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker