Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004940 [JEDI VCL] 00 JVCL Components minor always 2009-09-16 14:31 2009-10-02 10:21
Reporter drom296 View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.37
Summary 0004940: JvGradient Problems
Description During runtime, I need to change a property during runtime (i.e. the visible property) but it seems that it does not refresh instantly. As in when i change the property, there is no visual difference until another window is layered over the background. I have tried refreshing both the form and the gradient but the problem persists.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0016104)
obones (administrator)
2009-09-17 09:00

Please try with the latest version.
And if this still happens, please provide the zipped sources of a sample application showing this.
(0016218)
AHUser (developer)
2009-10-02 10:21

Cannot reproduce with SVN version.

Changing any property updates the gradiant (after the next WM_PAINT message is processed, what is by design).

- Issue History
Date Modified Username Field Change
2009-09-16 14:31 drom296 New Issue
2009-09-17 09:00 obones Note Added: 0016104
2009-09-17 09:00 obones Status new => feedback
2009-10-02 10:21 AHUser Note Added: 0016218
2009-10-02 10:21 AHUser Status feedback => resolved
2009-10-02 10:21 AHUser Fixed in Version => Daily / SVN
2009-10-02 10:21 AHUser Resolution open => fixed
2009-10-02 10:21 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker