Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004956 [JEDI VCL] 00 JVCL Components minor always 2009-09-24 09:49 2009-09-24 12:18
Reporter PascalKlaus View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004956: Value setting in JvValidateEdit with dfCurrency is not correct
Description The issue 0004903 isn't solved completely.
The problem was a JvValidateEdit with DisplayFormat = dfCurrency and a CurrencyString with the decimal separator character included.
The issue how described in 0004903: Putting in "SFr. 1234.00" sets the Value (and the text) to 0.12 is now solved. But backward, setting the value to 1234.00 sets text (and value itself) to 0.12
  
Additional Information With decimal separator in DisplaySuffix or -prefix, there is no problem since 0004903 and 0004952 is solved.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0016179)
obones (administrator)
2009-09-24 10:09

I don't understand the new problem.
Could describe it in details, along with the "CurrencyString" value as I did not see any obvious regression with the given fix.
(0016183)
PascalKlaus (reporter)
2009-09-24 10:56

With "Value" I mean the property of JvValidateEdit.
Local (windows) settings: Currencystring = 'SFr.', Decimal separator = '.'
You can reproduce that with a JvValidateEdit with property:
DisplayFormat: dfCurrency

Now put in a new property "Value" 1234.00 (in Delphis Objectinspector or in programm JvValidateEdit1.Value := 1234.00)

After exiting the Value field, this properties are shown:
Value: 0.1234
EditText: .123400
Text: SFr. 0.12
It seems that formatting of EditText is not correct
(0016184)
obones (administrator)
2009-09-24 12:18

Ah yes, thanks for the report, I missed that. This is now fixed in SVN.

- Issue History
Date Modified Username Field Change
2009-09-24 09:49 PascalKlaus New Issue
2009-09-24 10:09 obones Note Added: 0016179
2009-09-24 10:09 obones Status new => feedback
2009-09-24 10:56 PascalKlaus Note Added: 0016183
2009-09-24 12:18 obones Note Added: 0016184
2009-09-24 12:18 obones Status feedback => resolved
2009-09-24 12:18 obones Fixed in Version => Daily / SVN
2009-09-24 12:18 obones Resolution open => fixed
2009-09-24 12:18 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker