Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004976 [JEDI VCL] 00 JVCL Components minor always 2009-10-12 15:39 2011-06-10 16:09
Reporter Nazgul View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.37
Summary 0004976: TJvBalloonHint painting problem on Windows Vista
Description I am using a TJvBalloonHint. The message is overlapping the close button (see attached picture). This happens on Windows Vista. As far as I know, it is painted correctly on Windows XP.
Additional Information The message contains some unicode characters. They are displayed correctly.
Tags No tags attached.
Attached Files png file icon TJvBallonHint-bug.png [^] (5,789 bytes) 2009-10-12 15:39
? file icon 0004976.patch [^] (409 bytes) 2009-11-05 19:08

- Relationships

-  Notes
(0016858)
jkelley (reporter)
2009-11-05 19:08

I'm getting the same problem on a Windows XP system with themes enabled. The problem is apparently that TJvBalloonHint only takes into account the width of the header, not the width of the text, when placing its close button. The attached patch seems to fix it.
(0016860)
Nazgul (reporter)
2009-11-06 16:05

I have applied jkelley's patch to my 3.38 and it seems to have fixed the problem.

Thanks, jkelley.
(0016861)
AHUser (developer)
2009-11-06 16:58

Fixed in SVN. (It didn't make it into the 3.39 release)

- Issue History
Date Modified Username Field Change
2009-10-12 15:39 Nazgul New Issue
2009-10-12 15:39 Nazgul File Added: TJvBallonHint-bug.png
2009-11-05 19:08 jkelley Note Added: 0016858
2009-11-05 19:08 jkelley File Added: 0004976.patch
2009-11-06 16:05 Nazgul Note Added: 0016860
2009-11-06 16:58 AHUser Note Added: 0016861
2009-11-06 16:58 AHUser Status new => resolved
2009-11-06 16:58 AHUser Fixed in Version => Daily / SVN
2009-11-06 16:58 AHUser Resolution open => fixed
2009-11-06 16:58 AHUser Assigned To => AHUser
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker