Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004994 [JEDI VCL] 00 JVCL Components major always 2009-10-25 08:40 2009-10-25 15:01
Reporter tetardd View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.37
Summary 0004994: TJvTreeView: OnSelectionChange triggered several times in a row
Description In a TJvTreeView, when you select a node, the OnSelectionChange is triggered 2 or 3 times in a row.
Demo included:
Run it, clcik on a node. See you many times on OnSelectionChange is fired (the memo displays a new line when it's fired). You see that OnClick is fired once but up to 3 times for OnSelectionChange.
Additional Information
Tags No tags attached.
Attached Files zip file icon BugTJvTreeView.zip [^] (389,145 bytes) 2009-10-25 08:40

- Relationships

-  Notes
(0016809)
AHUser (developer)
2009-10-25 15:01

Fixed in SVN.

I have rewritten the whole MultiSelect part of the component which was the cause for this bug.

- Issue History
Date Modified Username Field Change
2009-10-25 08:40 tetardd New Issue
2009-10-25 08:40 tetardd File Added: BugTJvTreeView.zip
2009-10-25 15:01 AHUser Note Added: 0016809
2009-10-25 15:01 AHUser Status new => resolved
2009-10-25 15:01 AHUser Fixed in Version => Daily / SVN
2009-10-25 15:01 AHUser Resolution open => fixed
2009-10-25 15:01 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker