Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005000 [JEDI VCL] 00 JVCL Components block always 2009-10-29 08:26 2009-10-29 20:00
Reporter Cyrus View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005000: SVN Revision 12583 fails to install properly.
Description When trying to install JEDI VCL components using its own installer, these errors occur:

[Compiling: JvAppFrmD7R.bpl]
"\Borland\Delphi 7\Bin\dcc32.exe" JvAppFrmD7R.dpk
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
\delphi\jvcl\run\JvAppEvent.pas(294) Error: Undeclared identifier: 'OnModalBegin'
\delphi\jvcl\run\JvAppEvent.pas(294) Error: Not enough actual parameters
\delphi\jvcl\run\JvAppEvent.pas(295) Error: Undeclared identifier: 'OnModalEnd'
\delphi\jvcl\run\JvAppEvent.pas(295) Error: Not enough actual parameters
JvAppFrmD7R.dpk(63) Fatal: Could not compile used unit '..\..\run\JvAppEvent.pas'
Additional Information
Tags No tags attached.
Attached Files ? file icon JvAppEvent.pas.diff [^] (612 bytes) 2009-10-29 10:19

- Relationships

-  Notes
(0016844)
Cyrus (reporter)
2009-10-29 10:02

Looks like that TApplicationEvents does have OnModalBegin/OnModalEnd but they are protected class members.
(0016845)
Cyrus (reporter)
2009-10-29 10:21

I have attached patch which will fix this problem. This needs testing, thought.
(0016847)
AHUser (developer)
2009-10-29 20:00

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2009-10-29 08:26 Cyrus New Issue
2009-10-29 10:02 Cyrus Note Added: 0016844
2009-10-29 10:19 Cyrus File Added: JvAppEvent.pas.diff
2009-10-29 10:21 Cyrus Note Added: 0016845
2009-10-29 10:22 Cyrus Issue Monitored: Cyrus
2009-10-29 20:00 AHUser Note Added: 0016847
2009-10-29 20:00 AHUser Status new => resolved
2009-10-29 20:00 AHUser Fixed in Version => Daily / SVN
2009-10-29 20:00 AHUser Resolution open => fixed
2009-10-29 20:00 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker