Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005003 [JEDI VCL] 00 JVCL Components major always 2009-11-02 17:46 2009-11-02 19:01
Reporter ZENsan View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005003: JvAppEvent cause unforeseen bugs when using with JvDebugHandler.
Description When you TJvAppEvents to your application where TJvDebugHandler was used, you get doubled exceptions.
1) Exception dialog which is called from OnOtherDestination (in my sample). So for that this component was designed..
2) And then you get the default windows exception messagebox!

And all because of some "MultiCaster.DoException" from JvAppEvents.
Additional Information 1) Run project, you will see the exception like it must be.
2) Then uncomment the line in uses clause of Unit1.pas and run again - you will get the exception twice.
Tags No tags attached.
Attached Files zip file icon JvAppEvent.zip [^] (1,149 bytes) 2009-11-02 17:46

- Relationships

-  Notes
(0016849)
ZENsan (reporter)
2009-11-02 17:53

I think problem is raised from fix for 0004290.
The solution can be simple. By changing this Application.OnExeption on when TJvAppEvents.OnException is assigned. But there must be a way to avoid calling this exception dialogs twice.
(0016850)
AHUser (developer)
2009-11-02 18:35

The problem is not JvAppEvents but the inclusion of the unit AppEvnts. If the VCL unit is in a uses clause, TJvDebugHandler will always call the original handler which shows the default exception dialog.

The mentioned "simple solution" doesn't work because AppEvnts create the TMultiCaster in its initialization block.
(0016851)
AHUser (developer)
2009-11-02 19:01

Fixed in SVN.

TJvDebugHandler now uses the AppEvnts unit itself.

- Issue History
Date Modified Username Field Change
2009-11-02 17:46 ZENsan New Issue
2009-11-02 17:46 ZENsan File Added: JvAppEvent.zip
2009-11-02 17:53 ZENsan Note Added: 0016849
2009-11-02 18:35 AHUser Note Added: 0016850
2009-11-02 19:01 AHUser Note Added: 0016851
2009-11-02 19:01 AHUser Status new => resolved
2009-11-02 19:01 AHUser Fixed in Version => Daily / SVN
2009-11-02 19:01 AHUser Resolution open => fixed
2009-11-02 19:01 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker