Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005036 [JEDI VCL] 00 JVCL Components minor always 2009-11-27 21:19 2011-06-10 16:09
Reporter John Treder View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005036: TJvTimeEdit - OnChange never called; OnTopClick and OnBottomClick not published
Description If you add a handler for TJvTimeEdit's OnChange event, it's never called.
Tested in Delphi 2006, either XP or Vista. Drop a TJvTimeEdit on a new project, add a handler which can be a ShowMessage for this purpose, and run.
Additional Information I tried to derive a component surfacing OnTopClick and OnBottomClick. Neither of these is ever called either.
I suspect the problem is involved with the validation and formatting methods, but I didn't have time to study them in detail.
Tags No tags attached.
Attached Files zip file icon Project1.zip [^] (1,109 bytes) 2009-12-04 18:34

- Relationships

-  Notes
(0016948)
obones (administrator)
2009-12-04 15:29

Please send us the zipped sources of a sample application showing this
(0016967)
John Treder (reporter)
2009-12-04 18:35

Done.
(0016981)
obones (administrator)
2009-12-08 16:21

Confirmed for OnChange
(0016982)
obones (administrator)
2009-12-08 17:01

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2009-11-27 21:19 John Treder New Issue
2009-12-04 15:29 obones Note Added: 0016948
2009-12-04 15:29 obones Status new => feedback
2009-12-04 18:34 John Treder File Added: Project1.zip
2009-12-04 18:35 John Treder Note Added: 0016967
2009-12-08 16:21 obones Note Added: 0016981
2009-12-08 16:21 obones Status feedback => confirmed
2009-12-08 17:01 obones Note Added: 0016982
2009-12-08 17:01 obones Status confirmed => resolved
2009-12-08 17:01 obones Fixed in Version => Daily / SVN
2009-12-08 17:01 obones Resolution open => fixed
2009-12-08 17:01 obones Assigned To => obones
2010-07-05 20:56 dan59thx Issue Monitored: dan59thx
2010-07-05 20:56 dan59thx Issue End Monitor: dan59thx
2010-11-02 21:45 Henk Van Hoek Issue Monitored: Henk Van Hoek
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker