Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005043 [JEDI VCL] 00 JVCL Components major always 2009-12-03 10:05 2011-06-10 16:09
Reporter fschenckel View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005043: TJvIPAddress doesn't work
Description The component doesn't accept any input !

It happens also in design mode (doesn't accept any input !)
Additional Information Delphi 2009 / french Vista, french XP
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0016923)
obones (administrator)
2009-12-03 14:21

Please provide the zipped sources of a sample application showing this
(0016926)
fschenckel (reporter)
2009-12-04 12:38

Simply put a TJvIPAdress component on a form and try to set the Text property.
Address remains always to 0.0.0.0

At runtime you don't even get the focus on the component.
Seems to be the same with Delphi 2010.

Don't know what's your time frame is, but I can find some time in the few next days to give a look into the code to see if I can find the problem.
(0016927)
obones (administrator)
2009-12-04 14:40

Well it's actually larger than that, I'm seeing it with BDS2006 under XP as well.
Not sure why and if you have the time to debug it, please be my guest
(0016987)
fschenckel (reporter)
2009-12-09 19:46

I think, i've found the bug.

Don't know if it's the right correction but seems to work for me...


File JvComCtrls, at line 811 to 813 in
procedure TJvIPEditControlHelper.WndProc(var Msg: TMessage);
I've replaced the following code :
  with Msg do
    Result := DefWindowProc(Handle, Msg, WParam, LParam);

With
  Dispatch(Msg)

Like in older units !
(0017034)
obones (administrator)
2009-12-28 16:45

Yes, it's good, and in SVN

- Issue History
Date Modified Username Field Change
2009-12-03 10:05 fschenckel New Issue
2009-12-03 14:21 obones Note Added: 0016923
2009-12-03 14:21 obones Status new => feedback
2009-12-04 12:38 fschenckel Note Added: 0016926
2009-12-04 14:40 obones Note Added: 0016927
2009-12-04 14:40 obones Status feedback => confirmed
2009-12-09 19:46 fschenckel Note Added: 0016987
2009-12-28 16:45 obones Note Added: 0017034
2009-12-28 16:45 obones Status confirmed => resolved
2009-12-28 16:45 obones Fixed in Version => Daily / SVN
2009-12-28 16:45 obones Resolution open => fixed
2009-12-28 16:45 obones Assigned To => obones
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker