Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005049 [JEDI VCL] 00 JVCL Components major always 2009-12-08 14:11 2011-06-10 16:09
Reporter jam View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005049: TJvCpuUsage.Usage always returns 0 under Windows 7 x64
Description TJvCpuUsage.Usage always returns 0 under Windows 7 x64.
Additional Information The x86 Edition of Windows 7 does not seem to be affected, but all other 64Bit Windows editions seem to be affected. The call that fails is:

Status := NtQuerySystemInformation(SystemPerformanceInformation, @SysPerfInfo, SizeOf(SysPerfInfo), nil);
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017005)
obones (administrator)
2009-12-18 11:59

Does this also happen in XP x64?
(0017006)
jam (reporter)
2009-12-18 12:03

I tested a little more and found out that only Windows 7 x64 seems to be affected, but not XP64 or Vista64.
(0017041)
obones (administrator)
2009-12-29 09:55

Thanks for the report.
As I do not have access to Seven (either x86 or x64), someone else will have to look at that.
(0017119)
obones (administrator)
2010-01-13 22:33

This is confirmed in Seven x64
NtQuerySystemInformation is "undocumented" and so I'm not suprised of it not working. Need to find another solution.
(0017121)
obones (administrator)
2010-01-14 13:40

This should now be fixed in SVN, please try using the latest version

- Issue History
Date Modified Username Field Change
2009-12-08 14:11 jam New Issue
2009-12-18 11:59 obones Note Added: 0017005
2009-12-18 11:59 obones Status new => feedback
2009-12-18 11:59 obones Target Version => 3.40 - not yet released
2009-12-18 12:03 jam Note Added: 0017006
2009-12-29 09:55 obones Note Added: 0017041
2009-12-29 09:55 obones Status feedback => acknowledged
2010-01-13 22:33 obones Note Added: 0017119
2010-01-13 22:33 obones Status acknowledged => confirmed
2010-01-14 13:40 obones Note Added: 0017121
2010-01-14 13:40 obones Status confirmed => resolved
2010-01-14 13:40 obones Fixed in Version => Daily / SVN
2010-01-14 13:40 obones Resolution open => fixed
2010-01-14 13:40 obones Assigned To => obones
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker