Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005081 [JEDI VCL] 00 JVCL Components major always 2009-12-30 20:57 2010-01-04 20:35
Reporter VelhoMonge View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.38
Summary 0005081: JvOfficeColorButton raises an exception on Windows XP (compiled with D2010)
Description Hi,

The JvOfficeColorButton raises an exception on Windows XP (compiled with D2010). On Windows Vista, works fine.

Only occours when compiled with D2010...

Please verify atachamment.

Thanks.
Additional Information
Tags No tags attached.
Attached Files rar file icon D2010Bug_JvOfficeColorButton.rar [^] (507,936 bytes) 2009-12-30 20:57
jpg file icon bug_with_jvofficecolorbutton.JPG [^] (16,418 bytes) 2010-01-04 17:17

- Relationships

-  Notes
(0017061)
AHUser (developer)
2010-01-01 18:11

The attached example works for me (D2010, WinXP Prof).

What exception? Do you have the CallStack of the exception?
(0017067)
VelhoMonge (reporter)
2010-01-04 17:19

Please verify attached screenshot. I'm using Windows XP Professional SP3 and JvOfficeColorButton v3.38 + Delphi 2010. The message is "External Exception C0FB007F".
(0017068)
AHUser (developer)
2010-01-04 19:58

The "External Exception C0FB007F" is a known one that is already fixed.


You can read about it here:
http://andy.jgknet.de/blog/?p=660 [^]


In short:

There are 4 possible solutions:
   1. If you have used my binary JVCL installer, then redownload it. I have updated the download to contain the fix for this bug. Only the JVCL installer is new. The JCL isn’t affected by this bug.

      JVCL Binary Installer 3.38.0.1 ( http://cc.embarcadero.com/Item/27212 [^] )

   2. If you have installed the JVCL 3.38 source installation then you can replace the jvcl\run\JvThemes.pas by the updated JvThemes.pas ( http://jvcl.svn.sourceforge.net/viewvc/jvcl/trunk/jvcl/run/JvThemes.pas?view=log [^] ) and start the “jvcl\makemodified.bat” to recompile the JVCL.
   3. If you have installed a daily build then download a new daily build.
   4. If you have installed an SVN revision then update your SVN.

- Issue History
Date Modified Username Field Change
2009-12-30 20:57 VelhoMonge New Issue
2009-12-30 20:57 VelhoMonge File Added: D2010Bug_JvOfficeColorButton.rar
2010-01-01 18:11 AHUser Note Added: 0017061
2010-01-01 18:11 AHUser Status new => feedback
2010-01-04 17:17 VelhoMonge File Added: bug_with_jvofficecolorbutton.JPG
2010-01-04 17:19 VelhoMonge Note Added: 0017067
2010-01-04 19:58 AHUser Note Added: 0017068
2010-01-04 20:35 AHUser Status feedback => resolved
2010-01-04 20:35 AHUser Fixed in Version => 3.39
2010-01-04 20:35 AHUser Resolution open => fixed
2010-01-04 20:35 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker