Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005108 [JEDI VCL] 00 JVCL Components minor always 2010-01-14 19:58 2011-06-10 16:10
Reporter dcabale View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.37
Summary 0005108: TJvCustomCsvDataSet.Locate fails when setting a Filter
Description [TJvCustomCsvDataSet, TJvCsvDataSet]
all is said in the title.
A Filtered record should not be visible.
When a Dataset (or TJvCustomCsvDataSet) is filtered, the records that does not match the filter condition should not be returned with the TJvCustomCsvDataSet.Locate function ... But they are.
Additional Information to resolve this:

function TJvCustomCsvDataSet.Locate(const KeyFields: string; const KeyValues: Variant;
...
  for RecIndex := 0 to FData.Count - 1 do
  begin
///////////////////////////////////////
/// because don't need to trap filtered records
    if PCsvRow(FData.Items[RecIndex])^.Filtered then
       Continue;
/// end of adding
///////////////////////////////////////
...
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017123)
obones (administrator)
2010-01-15 08:55

Please try using the very latest JVCL, I believe this is already fixed.
(0017125)
dcabale (reporter)
2010-01-15 11:38

Hi,
the latest JvCsvData Id (from latest JVCL) is JvCsvData.pas 12533 2009-10-02 08:59:22Z, and it is the same version as the one used by the test (where the bug has been state). Is this a sufficient proof or do I need to reinstall the whole JCL + JVCL latest versions, and make the test with them ?
(0017398)
AHUser (developer)
2010-05-16 16:05

Fixed in SVN revision 12776

- Issue History
Date Modified Username Field Change
2010-01-14 19:58 dcabale New Issue
2010-01-15 08:55 obones Note Added: 0017123
2010-01-15 08:55 obones Status new => feedback
2010-01-15 11:38 dcabale Note Added: 0017125
2010-05-16 16:05 AHUser Note Added: 0017398
2010-05-16 16:05 AHUser Status feedback => resolved
2010-05-16 16:05 AHUser Fixed in Version => Daily / SVN
2010-05-16 16:05 AHUser Resolution open => fixed
2010-05-16 16:05 AHUser Assigned To => AHUser
2011-06-10 16:10 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker