Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005124 [JEDI VCL] 00 JVCL Components minor always 2010-01-24 04:27 2011-06-10 16:09
Reporter debose View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005124: Double click on TJvSpeedItem in TJvSpeedBar editor in design-time leads to malfunction procedure insertion in D2010
Description In Delphi 2010 (I haven't checked it in other versions)

Steps to reproduce:
* Place TjvSpeedBar on form
* double click on it to open SpeedBar editor
* click on Add button
* double-click on newly-added button

Error message box will appear:
---------------------------
Error
---------------------------
Expected an identifier but ':' found.
---------------------------
OK
---------------------------

Following procedure will be inserted in code editor:
procedure JvSpeedItem1Click(: );

Instead of
procedure JvSpeedItem1Click(Sender: TObject);
Additional Information Looks like error is in JVCL\design\JvSpeedBarForm.pas
in TJvSpeedbarEditorMain.ButtonsListDblClick procedure.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017245)
obones (administrator)
2010-03-08 15:42

Thanks, this is now fixed in SVN

- Issue History
Date Modified Username Field Change
2010-01-24 04:27 debose New Issue
2010-03-08 15:42 obones Note Added: 0017245
2010-03-08 15:42 obones Assigned To => obones
2010-03-08 15:42 obones Status new => resolved
2010-03-08 15:42 obones Resolution open => fixed
2010-03-08 15:42 obones Fixed in Version => Daily / SVN
2010-03-08 15:42 obones Target Version => 3.40 - not yet released
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker