Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005135 [JEDI VCL] 00 JVCL Components minor always 2010-01-25 11:21 2011-06-10 16:10
Reporter ReeBo View Status public  
Assigned To outchy
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005135: Physical-/Virtual-/Pagefile-Memory over 4 GB incorrect result by ComputerInfoEx
Description The Class ComputerInfoEx use the Windows-Api-Function GlobalMemoryStatus.
This function can only return values until 4GB.

Microsoft have implement a better function, called GlobalMemoryStatusEx.

Infos: http://msdn.microsoft.com/en-us/library/aa366586(VS.85).aspx [^]

Greets
ReeBo
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0005111resolvedoutchy JEDI Code Library GetTotalPhysicalMemory returns wrong values 

-  Notes
(0017321)
outchy (administrator)
2010-03-22 19:57

This should be fixed in JVCL revision 12732.

- Issue History
Date Modified Username Field Change
2010-01-25 11:21 ReeBo New Issue
2010-01-25 11:21 ReeBo IDE version => Delphi/C++Builder 2009
2010-01-25 17:14 Robert Rossmair Relationship added related to 0005111
2010-03-22 19:47 outchy Fixed in revision => 3213
2010-03-22 19:47 outchy Relationship replaced duplicate of 0005111
2010-03-22 19:47 outchy Duplicate ID 0 => 5111
2010-03-22 19:47 outchy Status new => resolved
2010-03-22 19:47 outchy Fixed in Version => Version 2.2 (Subversion repository/Daily zips)
2010-03-22 19:47 outchy Resolution open => duplicate
2010-03-22 19:47 outchy Assigned To => outchy
2010-03-22 19:55 outchy Project JEDI Code Library => JEDI VCL
2010-03-22 19:56 outchy Status resolved => feedback
2010-03-22 19:56 outchy Resolution duplicate => open
2010-03-22 19:56 outchy Category JclSysInfo => 00 JVCL Components
2010-03-22 19:56 outchy version Version 2.2 (Subversion repository/Daily zips) => Daily / SVN
2010-03-22 19:57 outchy Note Added: 0017321
2010-04-14 14:26 obones Status feedback => resolved
2010-04-14 14:26 obones Fixed in Version Version 2.2 (Subversion repository/Daily zips) => Daily / SVN
2010-04-14 14:26 obones Resolution open => fixed
2010-04-14 14:26 obones Duplicate ID 5111 => 0
2011-06-10 16:10 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker