Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005136 [JEDI VCL] 00 JVCL Components trivial always 2010-01-25 11:51 2011-06-10 16:09
Reporter debose View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005136: JvInterpreterNotepad demo fails to compile in D2010: Invalid typecast
Description Demo JVCL\examples\JvInterpreterDemos\JvInterpreterNotepad\ fails to compile in Delphi 2010.
Compilation fails on following code (last line):
procedure TMain.RAHLEditor1KeyUp(Sender: TObject; var Key: Word;
  Shift: TShiftState);
begin
  Args.Clear;
  Args.Values[0] := Key;
  Args.Values[1] := S2V(Byte(Shift));

Fail occur, because of Shift: TShitftState to byte typecast.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017251)
obones (administrator)
2010-03-08 16:05

No problem in D2009, must be checked with D2010
(0017352)
AHUser (developer)
2010-04-02 14:45

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2010-01-25 11:51 debose New Issue
2010-03-08 16:05 obones Note Added: 0017251
2010-03-08 16:05 obones Status new => acknowledged
2010-04-02 14:45 AHUser Note Added: 0017352
2010-04-02 14:45 AHUser Status acknowledged => resolved
2010-04-02 14:45 AHUser Fixed in Version => Daily / SVN
2010-04-02 14:45 AHUser Resolution open => fixed
2010-04-02 14:45 AHUser Assigned To => AHUser
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker