Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005140 [JEDI VCL] 00 JVCL Components minor have not tried 2010-01-26 12:46 2011-06-10 16:10
Reporter cecheto View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.33
Summary 0005140: Selecting a Thumbnail in TThumbView generates a List index out of bound after EmptyList call
Description If you have a populated TThumbView with a thumbnail selected, you clear all contents using EmptyList method and you insert new thumbnails, and the selected one was a higher index of the nre count, when you click on a new image you get a List Index out of bounds.
Additional Information This happens because the Selected property is not cleared when the EmptyList is executed and the SetSelected method tries clearing the highlighting of the previously selected thumbnail, and can be solved adding a "FSelected := -1" in the EmptyList method.
Also checking that the FSelected value in the SetSelected method could be an interesting correction. It only needs to be added "and (FSelected < Count)" in the "if (FSelected <> -1) then" line.

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017252)
obones (administrator)
2010-03-08 16:06

Please try with the latest version of the JVCL and let us know if it is still here
(0017396)
AHUser (developer)
2010-05-16 15:48

Fixed in SVN revision 12774

- Issue History
Date Modified Username Field Change
2010-01-26 12:46 cecheto New Issue
2010-03-08 16:06 obones Note Added: 0017252
2010-03-08 16:06 obones Status new => feedback
2010-05-16 15:48 AHUser Note Added: 0017396
2010-05-16 15:48 AHUser Status feedback => resolved
2010-05-16 15:48 AHUser Fixed in Version => Daily / SVN
2010-05-16 15:48 AHUser Resolution open => fixed
2010-05-16 15:48 AHUser Assigned To => AHUser
2011-06-10 16:10 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker