Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005166 [JEDI VCL] 00 JVCL Components minor always 2010-02-11 16:44 2011-06-10 16:09
Reporter lguillau View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005166: In JvUrlListGrabber.pas, procedure ParseUrl, Error parsing the Port part of the URL
Description In JvUrlListGrabber.pas, procedure ParseUrl, the code in charge of parsing the host and port part of the url seems to be incorrect. (at the end of the procedure)
The code:
  Host := Copy(Host, 1, Pos(':', Host) - 1);
  Port := StrToIntDef(Copy(Host, Pos(':', Host) + 1, Length(Host)), 0);
should be changed to (just line swapping):
  Port := StrToIntDef(Copy(Host, Pos(':', Host) + 1, Length(Host)), 0);
  Host := Copy(Host, 1, Pos(':', Host) - 1);
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017264)
obones (administrator)
2010-03-08 16:42

Thanks, this is now fixed in SVN

- Issue History
Date Modified Username Field Change
2010-02-11 16:44 lguillau New Issue
2010-03-08 16:42 obones Note Added: 0017264
2010-03-08 16:42 obones Assigned To => obones
2010-03-08 16:42 obones Status new => resolved
2010-03-08 16:42 obones Resolution open => fixed
2010-03-08 16:42 obones Fixed in Version => Daily / SVN
2010-03-08 16:42 obones Target Version => 3.40 - not yet released
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker