Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005181 [JEDI VCL] 00 JVCL Components minor always 2010-02-24 17:18 2012-02-29 16:55
Reporter tbd View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005181: JvDBGrid. JvDBUltimGrid
Description When dgIndicator in Options and UseXPThemes is true and any (XP) Theme is turned on in Windows, then indicator always shows as default indicator (black triangle), but I am inserting (must be a star, but show a black triangle) or editing (must be a "vertical line", but show a black triangle) a record.

Sorry, my English. :)
Additional Information
Tags No tags attached.
Attached Files zip file icon JVDBUGTest.zip [^] (11,431 bytes) 2010-03-09 20:51

- Relationships

-  Notes
(0017214)
tbd (reporter)
2010-02-24 17:19

Indicator
(0017270)
obones (administrator)
2010-03-09 11:02

Please provide the zipped sources of a sample application showing this
(0017298)
tbd (reporter)
2010-03-09 20:55

I uploaded the source code. Thank you. :)
(0017359)
przemm07 (reporter)
2010-04-10 13:13

Not only indicator appears wrong but all indicator bar and title bar.
When UseXPThemes is disabled and in project options "Enable runtime themes" is checked then indicator and all indicator bar is ok but title bar is wrong
(0017360)
tbd (reporter)
2010-04-10 22:24

"Not only indicator...":
It is possible (I do not know).

I am using Delphi 7 and I not found "Enable runtime themes" in project options or maybe I searched it in wrong place. I am sorry to say just now.

I searched on Internet and I think that the "Enable runtime themes" option appeared in Delphi 2007.
(0017773)
obones (administrator)
2010-10-08 14:56

Is this still here in the latest version?
(0017852)
tbd (reporter)
2010-10-10 09:50

Unfortunately, yes.

I am using version 3.40 (Published: 2010-09-12)
(0018051)
obones (administrator)
2010-11-09 14:43

Someone with themes support will have to test this
(0018136)
tbd (reporter)
2010-11-18 19:11

I read just now your last comment, because I did not get an e-mail about this comment.

What should I do, if I am the someone? :-)
(0018211)
AHUser (developer)
2010-11-28 14:21

Fixed in svn revision 12930.

- Issue History
Date Modified Username Field Change
2010-02-24 17:18 tbd New Issue
2010-02-24 17:19 tbd Note Added: 0017214
2010-02-24 17:23 tbd Issue Monitored: tbd
2010-02-24 17:23 tbd Issue End Monitor: tbd
2010-03-09 11:02 obones Note Added: 0017270
2010-03-09 11:02 obones Status new => feedback
2010-03-09 20:51 tbd File Added: JVDBUGTest.zip
2010-03-09 20:55 tbd Note Added: 0017298
2010-04-10 13:13 przemm07 Note Added: 0017359
2010-04-10 22:24 tbd Note Added: 0017360
2010-10-08 14:56 obones Note Added: 0017773
2010-10-10 09:50 tbd Note Added: 0017852
2010-11-09 14:43 obones Note Added: 0018051
2010-11-09 14:43 obones Status feedback => acknowledged
2010-11-18 19:11 tbd Note Added: 0018136
2010-11-28 14:21 AHUser Note Added: 0018211
2010-11-28 14:21 AHUser Status acknowledged => resolved
2010-11-28 14:21 AHUser Fixed in Version => Daily / SVN
2010-11-28 14:21 AHUser Resolution open => fixed
2010-11-28 14:21 AHUser Assigned To => AHUser
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker