Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005194 [JEDI VCL] 00 JVCL Components block always 2010-03-15 03:17 2011-06-10 16:09
Reporter BoChenLin View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.38
Summary 0005194: Right click on a TJvCaptionPanel's caption bar blocks right click on other controls
Description 1. Right click on a TJvCaptionPanel's caption bar, release mouse click.
2. Right click on other controls on the same form.
3. It actually still triggers TJvCaptionPanel's mouse events, not the one is been clicking.
4. This only happens when the TJvCaptionPanel's AutoDrag is set to true.
Additional Information The Severity is "block" because in my case, I have a grid on the caption panel, user can right click on the grid's header to bring up a popup menu to change the which columns to be visible. But the header is just below the panel's caption bar, if the user clicks on the bar when they are trying to click on the header, then no matter how hard he/she tries to right click again on the header, nothing will happen until he/she "accidentally" left click somewhere else.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017309)
AHUser (developer)
2010-03-16 23:12

Fixed in SVN.

In MouseUp the call to ReleaseCapture() was missing

- Issue History
Date Modified Username Field Change
2010-03-15 03:17 BoChenLin New Issue
2010-03-16 23:12 AHUser Note Added: 0017309
2010-03-16 23:12 AHUser Status new => resolved
2010-03-16 23:12 AHUser Fixed in Version => Daily / SVN
2010-03-16 23:12 AHUser Resolution open => fixed
2010-03-16 23:12 AHUser Assigned To => AHUser
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker