Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005207 [JEDI VCL] 00 JVCL Components major always 2010-03-23 16:37 2011-06-10 16:09
Reporter Thor View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005207: stack overflow testing sample of issue 0005190
Description Hi,

i've just done an update with the current svn and rebuild the jvl and jvcl
for testing the resolution of issue 0005190 but ... when i open the project
that i've sended some days ago attacched on issue 0005190 and i try to run it, i get a "Stack Overflow" when the program do "CDS1.open" ... if i try at designtime to active the table then the grid populate without error ... doh!
What's happened ?
Additional Information
Tags No tags attached.
Attached Files

- Relationships
child of 0005190resolvedAHUser jvDBlookup don't refresh displayValue when lookupindex is the same value of the previous 

-  Notes
(0017323)
Thor (reporter)
2010-03-25 09:01

other test that i've done :
- the stack overflow appear also in other program that worked previous of the last update
- deleted all the jvcl and jcl directory and re-downloaded all. Same problem
- done 2 revision downgrade. Same problem
- deleted all. Copied an old version. All worked well as before !
- upgraded only JvDBLookup.pas from the current SVN. All worked well ... but the component don't do automatic refresh as stated in the resolve of 5190. I need to call the ForceDisplay procedure that i've seen it's included in the current branch.

my conclusion: the problem is elsewhere in the upgrade of the jedi component and not in the new JvDBLookup.pas but it's a severe problem because i can't upgrade all the svn now ...
(0017326)
Thor (reporter)
2010-03-29 11:59

Hello,

i've had the time to do some other test :
- Deleted all an re-downloaded to the current svn
- installed jcl and jvcl
- tested the program attached in 5190 (after commented out the ForceDisplay), result : stack overflow !
- downgraded only the JvDBLookup.pas to the revision 12723
- tested the program attached in 5190 (after commented out the ForceDisplay) result : all goes well, doesn't crash (but the bug of 5190 is not fixed in this version)

so my previous conclusion was not correct :-)
the is really in the JvDBLookup.pas
(0017329)
nestor (reporter)
2010-03-29 15:41

I do the same, no more stack overflow.
Thanks for your time
(0017330)
AHUser (developer)
2010-03-29 18:04

Fixed in SVN.
The "Locate" that is executed by the grid started a endless recursion of DataLink events.

- Issue History
Date Modified Username Field Change
2010-03-23 16:37 Thor New Issue
2010-03-24 09:09 Thor Issue Monitored: Thor
2010-03-24 18:59 outchy Relationship added child of 0005190
2010-03-25 09:01 Thor Note Added: 0017323
2010-03-28 16:53 nestor Issue Monitored: nestor
2010-03-29 11:59 Thor Note Added: 0017326
2010-03-29 15:41 nestor Note Added: 0017329
2010-03-29 18:04 AHUser Note Added: 0017330
2010-03-29 18:04 AHUser Status new => resolved
2010-03-29 18:04 AHUser Fixed in Version => Daily / SVN
2010-03-29 18:04 AHUser Resolution open => fixed
2010-03-29 18:04 AHUser Assigned To => AHUser
2010-03-30 09:21 Thor Issue End Monitor: Thor
2011-06-10 16:09 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker