Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005237 [JEDI VCL] 00 JVCL Components minor always 2010-05-14 07:20 2012-02-23 10:05
Reporter gpcaretti View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version 3.39
Summary 0005237: [TJvDBUltimGrid] On master-details view the 'sort title' action looses the details
Description If you have two TJvDBUltimGrid, one for the master table and one for the details table, the details grid shows no rows if you sort with respect to a key that is not the master-details relational key, by pressing the title buttons.
Additional Information Conditions for the details TJvDBUltimGrid:
'SortWith' = swFields or swWhere
TitleButtons = True

Use Case:
1. Open a master-detail form using 2 TJvDBUltimGrid
2. By pressing a column title, sort the details grid with respect to a field
3. Now move to another master row on the master grid
You will see no rows are shown on the details grid.

The reason seems to be the fact that when you press the title button to sort, the code modify the 'IndexFieldNames' property of the details TJvDBUltimGrid is changed, but if in the IndexFieldNames there is not the master-details relational key, the details grid shows no rows
Tags No tags attached.
Attached Files zip file icon TestDBUltimGridSort.zip [^] (8,197 bytes) 2010-07-09 12:34

- Relationships

-  Notes
(0017455)
obones (administrator)
2010-06-07 13:50

Could you please provide the zipped sources of a sample application showing this?
(0017531)
gpcaretti (reporter)
2010-07-09 12:34

Provided as zipped project.
(0017799)
obones (administrator)
2010-10-08 15:57

Thanks, someone with DB knowledge will look at this
(0018776)
stevegr (reporter)
2011-06-18 11:13

I checked this with ADO.
I used DataSetProvider and TClientDataset for the master dataset and it work ok.
(SortWith:=swClient)

Contributed code: issue 5601
(0018784)
stevegr (reporter)
2011-06-19 18:14

Could not reproduce the error.
(0019491)
obones (administrator)
2012-02-23 10:05

Thanks, then I believe it is already fixed

- Issue History
Date Modified Username Field Change
2010-05-14 07:20 gpcaretti New Issue
2010-05-15 03:05 gpcaretti Issue Monitored: gpcaretti
2010-06-07 13:50 obones Note Added: 0017455
2010-06-07 13:50 obones Status new => feedback
2010-07-09 12:34 gpcaretti File Added: TestDBUltimGridSort.zip
2010-07-09 12:34 gpcaretti Note Added: 0017531
2010-10-08 15:57 obones Note Added: 0017799
2010-10-08 15:57 obones Status feedback => acknowledged
2011-06-18 11:13 stevegr Note Added: 0018776
2011-06-19 18:14 stevegr Note Added: 0018784
2012-02-23 10:05 obones Note Added: 0019491
2012-02-23 10:05 obones Status acknowledged => resolved
2012-02-23 10:05 obones Resolution open => unable to reproduce
2012-02-23 10:05 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker