Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005266 [JEDI VCL] 00 JVCL Components major always 2010-06-18 15:47 2012-02-29 16:55
Reporter adit_bose View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005266: Error in JvCsvDataSet Filter
Description Dear All,
I've faced problem with JvCsvDataSet Filter.
I shall be grateful, if anyone can solve it.
I've attached files, and made it very simple.

JvCsvDataSet Filter returns a Result, even when non-matching Criteria is given.
In the program, when "Box" or "Carton" is selected, result is fine (correctly filtered); but when "Garments" is selected, it returns the first record from database (csv file) although there are NO record(s) of Garments in the database.

Any solution ??

Thank u all in advance.
Additional Information
Tags No tags attached.
Attached Files zip file icon Source Files.zip [^] (1,754 bytes) 2010-06-18 15:47

- Relationships
has duplicate 0005280resolvedobones Error in JvCsvDataSet Filter 

-  Notes
(0017807)
obones (administrator)
2010-10-08 16:01

Thanks, someone with DB knowledge will have to look at this
(0018181)
AHUser (developer)
2010-11-27 15:11

Fixed in svn revision 12908.
RecordCount always returned all records even if a filter was specified. But you shouldn't use RecordCount to iterate over a DataSet anyway. A "while not JvCsvDataSet1.Eof do" loop is the better way and it would have worked because EOF is set correctly.

- Issue History
Date Modified Username Field Change
2010-06-18 15:47 adit_bose New Issue
2010-06-18 15:47 adit_bose File Added: Source Files.zip
2010-06-18 15:47 adit_bose IDE version => Delphi/C++Builder 2009
2010-06-22 09:26 outchy Project JEDI Code Library => JEDI VCL
2010-06-22 09:27 outchy Category Miscellanous => 00 JVCL Components
2010-06-22 09:27 outchy version => 3.39
2010-08-20 11:44 obones Status new => acknowledged
2010-10-08 16:01 obones Note Added: 0017807
2010-10-08 16:04 obones Relationship added has duplicate 0005280
2010-11-27 15:11 AHUser Note Added: 0018181
2010-11-27 15:11 AHUser Status acknowledged => resolved
2010-11-27 15:11 AHUser Fixed in Version => Daily / SVN
2010-11-27 15:11 AHUser Resolution open => fixed
2010-11-27 15:11 AHUser Assigned To => AHUser
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker