Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005297 [JEDI VCL] 00 JVCL Components major sometimes 2010-08-14 04:33 2012-02-29 16:55
Reporter Kiriakos View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005297: JvDocking Floating form not drawing correctly
Description Docking style VSNet
When I drag form from a docked state to a floating state *sometimes* it is not painted correctly.
Additional Information Fix:
In JvDockSupportForm procedure DoFloatForm insert one line:

  procedure DoFloatForm(Control: TControl);
  var
    WasVisible: Boolean;
  begin
    if Control.FloatingDockSiteClass = Control.ClassType then
    begin
      WasVisible := Control.Visible;
      try
        DragObject.AlphaBlendedForm.Hide; // line inserted
        Control.Dock(nil, DragObject.DockRect);
        if (Control.Left <> DragObject.DockRect.Left) or (Control.Top <> DragObject.DockRect.Top) then
        begin
          Control.Left := DragObject.DockRect.Left;
          Control.Top := DragObject.DockRect.Top;
        end;
      finally
        if WasVisible then
          Control.BringToFront;
      end;
    end;
  end;

This extra line hides the alpha blended form before showing the floating form.

Also while we are at it there is absolutely no reason for TJvAlphaBlendedForm to inherit from TJvForm.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017606)
obones (administrator)
2010-08-20 11:49

Please provide the zipped sources of a sample application showing this
(0017629)
Kiriakos (reporter)
2010-08-30 04:55

I had this problem with PyScripter (sources at pyscripter.googlecode.com) and it would be hard to reproduce in a simple example.

However, if you see what the change is doing it is hiding the AlphaBlended form used while dragging forms, before making visible the dragged form. This is good practice anyway and cannot do any harm. In the problem I had, when the AlphaBlended form was hidden/destroyed it messed up the appearance of the already shown dragged form for some unknown reason.

By the way I am the contributor of the AlphaBlended stuff.
(0017683)
Kiriakos (reporter)
2010-09-16 22:31

Actually the problem is reproducible with the DockingInCode JvDocking demo in Windows 7.

- Run the demo.
- Press the Conjoined dock button.
- Drag a form to a floating position.

The form is not painted properly.
(0017863)
obones (administrator)
2010-10-11 10:12

Someone with Win7 will have to look at this, provided it is not already fixed in SVN
(0018216)
AHUser (developer)
2010-11-28 15:26

Fixed in svn revision 12934.

- Issue History
Date Modified Username Field Change
2010-08-14 04:33 Kiriakos New Issue
2010-08-20 11:49 obones Note Added: 0017606
2010-08-20 11:49 obones Status new => feedback
2010-08-30 04:55 Kiriakos Note Added: 0017629
2010-09-16 22:31 Kiriakos Note Added: 0017683
2010-10-11 10:12 obones Note Added: 0017863
2010-10-11 10:12 obones Status feedback => acknowledged
2010-11-28 15:26 AHUser Note Added: 0018216
2010-11-28 15:26 AHUser Status acknowledged => resolved
2010-11-28 15:26 AHUser Fixed in Version => Daily / SVN
2010-11-28 15:26 AHUser Resolution open => fixed
2010-11-28 15:26 AHUser Assigned To => AHUser
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker