Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005299 [JEDI VCL] 00 JVCL Components minor always 2010-08-15 09:48 2012-02-29 16:53
Reporter GreyWolf1983 View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.38
Summary 0005299: With certain settings, captions of pages of TJvgPageControl are not displayed on x64 Windows 7
Description When I use TJvgPageControl and set its TabPosition to tpLeft and TabsPosition to fsdTop, on 64-bit versions of Windows 7 caption text of TabSheets are not displayed. I use Delphi 7 to create executable.
Additional Information
Tags No tags attached.
Attached Files png file icon display_error.png [^] (1,033 bytes) 2010-08-15 09:48

- Relationships

-  Notes
(0017582)
obones (administrator)
2010-08-15 21:37

The Globus components (those with Jvg prefixes) are being deprecated.
The recommended replacement for TJvgPageControl is TJvPageControl which should contain all the functionality you need minus the bugs in the "Globus" versions.
(0017585)
GreyWolf1983 (reporter)
2010-08-16 18:24

Thank you for suggestion, but TJvPageControl does not have ability to layout tabs' caption text horizontally in case when tabs are located at the left of control, not at the top. TJvPageControl renders such tabs caption text in vertical direction, from bottom to top, while I need horizontal, left to right. The problem is that personally I don't have access to x64 bit system, so I can't reproduce and try to fix this issue, which was reported by users of my program.
(0017677)
dejanm73sf (reporter)
2010-09-16 02:29

I have the same issue with TJvgPageControl - when TabPosition is tpLeft and TabsPosistion is fsdLeft I set the FontDirection to fldDownUp and the caption on tab sheet is not shown. I have traced this to change in JvgPage.pas where JvJVCLUtils was put into the uses clause after JvgUtils. I have swapped these two around and caption is now working for above mentioned settings.

After that I have also changed other units that had JvJVCLUtils unit added after JvgUtils unit. Here is the list of changes. I have only tested the above mentioned change.

JvgAskListBox.pas moved JvJVCLUtils before JvgUtils
JvgCrossTable.pas moved JvJVCLUtils from implementation to interface uses after JvComponentBase
JvgImage.pas moved JvJVCLUtils from implementation to interface uses after JvComponent
JvgPage.pas moved JvJVCLUtils before JvgUtils
JvgShadow.pas moved JvJVCLUtils before JvgUtils
JvgTab.pas moved JvJVCLUtils from implementation to interface uses after JVCLVer
(0017678)
obones (administrator)
2010-09-16 09:09

I would very much prefer if you could find out which function of JvJVCLUtils is the culprit.
(0017679)
dejanm73sf (reporter)
2010-09-16 09:46

In case of JvgPage.pas it was CreateRotatedFont function that was causing the issue. Version in JvJVCLUtils has the same signature as JvgUtils but code in JvgPage.pas must expect the version from JvgUtils.

As I said I haven't tested other units that had the JvJVCLUtils unit added to uses clause after JvgUtils unit but since the changes to the rest of the code were minimal I believe that for those units JvgUtils should come after JvJVCLUtils in uses clause. Even the naming convention suggests the same, JvJVCLUtils is the collection of utilities for the entire JVCL and JvgUtils is the collection for just the Globus components so it should be preferred to common unit in Jvg* units.
(0017864)
obones (administrator)
2010-10-11 10:19

This is now changed in SVN

- Issue History
Date Modified Username Field Change
2010-08-15 09:48 GreyWolf1983 New Issue
2010-08-15 09:48 GreyWolf1983 File Added: display_error.png
2010-08-15 09:51 GreyWolf1983 Issue Monitored: GreyWolf1983
2010-08-15 21:37 obones Note Added: 0017582
2010-08-15 21:37 obones Status new => feedback
2010-08-16 18:24 GreyWolf1983 Note Added: 0017585
2010-09-16 02:29 dejanm73sf Note Added: 0017677
2010-09-16 09:09 obones Note Added: 0017678
2010-09-16 09:46 dejanm73sf Note Added: 0017679
2010-10-11 10:19 obones Note Added: 0017864
2010-10-11 10:19 obones Status feedback => resolved
2010-10-11 10:19 obones Fixed in Version => Daily / SVN
2010-10-11 10:19 obones Resolution open => fixed
2010-10-11 10:19 obones Assigned To => obones
2012-02-29 16:53 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker