Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005311 [JEDI VCL] 00 JVCL Components minor always 2010-08-26 10:01 2012-02-29 16:53
Reporter ralfiii View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005311: Height can't be set below 21 for TJvDateEdit/TJvComboEdit/TJvMaskEdit
Description When the borderstyle of one of TJvComboEdit is set to bsNone it should generally be possible to make the component (in the IDE) smaller.

The original VCL-MaskEdit can even be made as small as you like no
matter which borderstyle.
All the Jedi-components mentioned above can't be made smaller (On my screen they
always stay at a minimum of 21 pixels).

In TJvCustomComboEdit there's even code that checks for that
(GetMinHeight), but it seems to be overruled somewhere.
Additional Information
Tags No tags attached.
Attached Files ? file icon JvCustomComboEdit_SetHeight.patch [^] (912 bytes) 2010-08-26 10:02

- Relationships

-  Notes
(0017628)
ralfiii (reporter)
2010-08-26 10:02

The problem was located in TJvCustomComboEdit.AdjustHeight - BorderStyle was ignored.
Patch attached.
(0017859)
obones (administrator)
2010-10-11 09:59

Thanks, this is now in SVN

- Issue History
Date Modified Username Field Change
2010-08-26 10:01 ralfiii New Issue
2010-08-26 10:02 ralfiii Note Added: 0017628
2010-08-26 10:02 ralfiii File Added: JvCustomComboEdit_SetHeight.patch
2010-10-11 09:59 obones Note Added: 0017859
2010-10-11 09:59 obones Status new => resolved
2010-10-11 09:59 obones Fixed in Version => Daily / SVN
2010-10-11 09:59 obones Resolution open => fixed
2010-10-11 09:59 obones Assigned To => obones
2012-02-29 16:53 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker