Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005322 [JEDI VCL] 00 JVCL Components feature always 2010-09-03 17:04 2011-06-10 16:10
Reporter andersonfranco View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005322: TJvHLEditor is not performing Global Copy/Paste again
Description It seems the reported bug http://issuetracker.delphi-jedi.org/view.php?id=4521 [^] is back.

I´m using Delphi 2010 and Win7.
Additional Information to reproduce:
1) create a new application
2) put a TJvHLEditor
3) execute
4) Copy the text above and past it in JvHLEditor. The text won´t be exactly the same.


/* Table: TEST, Owner: SYSDBA */

CREATE TABLE "TEST"
(
  "C1" INTEGER NOT NULL,
  "C2" NUMERIC(12, 2),
  "C3" VARCHAR(40) COLLATE PXW_INTL850,
CONSTRAINT "PK_TEST" PRIMARY KEY ("C1")
);

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017641)
andersonfranco (reporter)
2010-09-03 18:38

When you see "above" it means "below". Sorry my bad english :-(
(0017642)
AHUser (developer)
2010-09-03 18:46

I can't reproduce this. The CREATE TABLE appears as expected in the editor.

1. Create a new VCL Delphi Win32 Forms-Application
2. Put a TJvHLEditor component on the form
3. Save the project
4. Compile and Run the application
5. Paste "/* Table: TEST, ...." text into the editor.
(0017643)
andersonfranco (reporter)
2010-09-03 19:06

You are right! Copying the text from here worked properly.

I tried on with another piece of firebird script, copying from notepad to JvHLEdit:

CREATE TABLE "TELE"
(
  "CODIGO" INTEGER NOT NULL,
  "DATA" DATE,
  "PERIODO" VARCHAR(1) COLLATE PXW_INTL850,
CONSTRAINT "PK_TELE" PRIMARY KEY ("CODIGO")
);

And I got the following result: http://www.bitbar.com.br/pub/jvHLEditor.png [^]
(0017644)
andersonfranco (reporter)
2010-09-03 19:09

Again, copying the text from this web page worked. I´m lost now.
(0017645)
AHUser (developer)
2010-09-03 20:35

Maybe there are some non-printable charaters (escape codes) in the text that are lost if you put them in here.
(0017646)
andersonfranco (reporter)
2010-09-03 21:24

I´ve looked at code with an hex editor and I could only see tabs (0000009) which I believe are normal in a text.

If you don´t mind, could you to try copy/paste with the files, please ? The first one is ok, but second doen´t work.

http://www.bitbar.com.br/pub/without-tabs.txt [^]
http://www.bitbar.com.br/pub/with-tabs.txt [^]

Thank you.
(0017647)
AHUser (developer)
2010-09-03 22:27

Now I can reproduce the bug.
(0017648)
AHUser (developer)
2010-09-03 23:25

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2010-09-03 17:04 andersonfranco New Issue
2010-09-03 18:38 andersonfranco Note Added: 0017641
2010-09-03 18:46 AHUser Note Added: 0017642
2010-09-03 18:46 AHUser Assigned To => AHUser
2010-09-03 18:46 AHUser Status new => feedback
2010-09-03 19:06 andersonfranco Note Added: 0017643
2010-09-03 19:09 andersonfranco Note Added: 0017644
2010-09-03 20:35 AHUser Note Added: 0017645
2010-09-03 21:24 andersonfranco Note Added: 0017646
2010-09-03 22:27 AHUser Note Added: 0017647
2010-09-03 23:25 AHUser Note Added: 0017648
2010-09-03 23:25 AHUser Status feedback => resolved
2010-09-03 23:25 AHUser Fixed in Version => Daily / SVN
2010-09-03 23:25 AHUser Resolution open => fixed
2011-06-10 16:10 obones Fixed in Version Daily / SVN => 3.40


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker