Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005325 [JEDI VCL] 00 JVCL Components major always 2010-09-06 16:27 2012-02-29 16:55
Reporter dreel View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005325: JvMemoryData don't load
Description JvMemoryData attached to TADOQuery, DataSource linked to JvMemoryData.
DBGrid views the data from DataSource.

JvMemoryData has 2 AdtField with Child Fields.

So after open last 2 columns in JvMemoryData stay blank, but TADOQuery directly attached to the same DBGrid shows all data fine.

I think it's all about CopyFromDataSet procedure counting fields wrong if there any AdtField.
Additional Information
Tags adt, adtfield, Calculated, Delphi 7.0, Field, JvMemoryData
Attached Files zip file icon Jvcl_issue0005325.zip [^] (8,743 bytes) 2010-10-26 09:13

- Relationships

-  Notes
(0017830)
obones (administrator)
2010-10-08 16:30

Please provide the zipped sources of a sample application showing this
(0017957)
dreel (reporter)
2010-10-26 09:15

Simple application reproducing the bug http://issuetracker.delphi-jedi.org/file_download.php?file_id=0002018&type=bug [^]

I've found the dependency from existing Calculated fields.

JvMemoryData.LoadData = Enabled
It Looks like LoadStructure takes FieldCount = JvMemData.FieldsCount - CalcFieldsCount.

See the example for details.
(0018198)
AHUser (developer)
2010-11-28 01:35

Fixed in svn revision 12921.

- Issue History
Date Modified Username Field Change
2010-09-06 16:27 dreel New Issue
2010-09-06 16:29 dreel Tag Attached: Delphi 7.0
2010-09-06 16:29 dreel Tag Attached: adt
2010-09-06 16:29 dreel Tag Attached: adtfield
2010-09-06 16:29 dreel Tag Attached: JvMemoryData
2010-09-06 16:29 dreel Issue Monitored: dreel
2010-10-08 16:30 obones Note Added: 0017830
2010-10-08 16:30 obones Status new => feedback
2010-10-26 09:12 dreel Tag Attached: Calculated
2010-10-26 09:12 dreel Tag Attached: Field
2010-10-26 09:13 dreel File Added: Jvcl_issue0005325.zip
2010-10-26 09:15 dreel Note Added: 0017957
2010-11-28 01:35 AHUser Note Added: 0018198
2010-11-28 01:35 AHUser Status feedback => resolved
2010-11-28 01:35 AHUser Fixed in Version => Daily / SVN
2010-11-28 01:35 AHUser Resolution open => fixed
2010-11-28 01:35 AHUser Assigned To => AHUser
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker