Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005335 [JEDI VCL] 00 JVCL Components major always 2010-09-18 21:45 2012-02-29 16:55
Reporter tetardd View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005335: Call Inherited in CNNotify TJvDateTimePicker missing
Description In the CNNotify method of TJvDateTimePicker, the following code exists:

DTN_CLOSEUP:
 begin
 end;

Inherited is not called and therefore, FDroppedDown not updated (as in the ancestor in the TDateTimePicker component) and stay to True forever.
Please correct to:

DTN_CLOSEUP:
 begin
     Inherited;
 end;


 
Additional Information
Tags No tags attached.
Attached Files 7z file icon DatePicker_BDS-XE.7z [^] (934,328 bytes) 2010-11-11 02:28

- Relationships
related to 0004651resolvedobones TJvDBDatePicker 
related to 0005330resolvedobones Override CheckValidDate of JvDateTimePicker to avoid NullDate 

-  Notes
(0017685)
obones (administrator)
2010-09-20 10:47

This is because of Mantis 0004651
If you find a fix for both issues, then please post it
(0017703)
tetardd (reporter)
2010-09-23 13:38

I added the "Inherited" as I suggest and I tried to reproduce the bug in Mantis 0004651 and I don't have the exception as it's claimed (I have D2010 so maybe it's dependent on the version of Delphi).

Therefore, I think that calling "Inherited" seems to work OK.
(0017704)
tetardd (reporter)
2010-09-23 13:46

Note that in my test, I also incorporated my suggested fix in 0005330 so that could be the fixes: put "Inherited" back and implement 0005330 as I requested.
(0017867)
obones (administrator)
2010-10-11 10:37

I can't reproduce it either in D2010, but it would need to be tried again with earlier versions
(0018080)
Arioch (developer)
2010-11-11 02:11

-2) as i remember in old Mantis there was header "Delphi/BCB version" as platform.
I wish this field be revived and made required.

-1) if no one can test on Delphi below 2010 then it can be if-def'ed to be at least reverted in Dephi 2010+

0) Maybe it'd even be just reverted at all and comment left in sources that for future bug reports on this, Delphi version is critical info.
This might be cynical yet ony practical way to test it in someone's older Delphi

1) instead of adding dumb-plain "inherited" call, it woud be better to just remove those lines.

2) and instead of placing this silencer in TJvDateTimePicker.CNNotify, it would better be moved to TJvDBDateTimePicker.CNNotify
If DB-component really need to be crippled, then at least let it be only the DB-component, not both components at once!
(0018081)
Arioch (developer)
2010-11-11 02:14

just tried 0004651 in Delphi XE - i reverted ths 'patch' as i wrote in NNTP - and got infamous

---------------------------
Debugger Exception Notification
---------------------------
Project DatePicker.exe raised exception class EDateTimeError with message 'You must be in ShowCheckbox mode to set to this date'.
---------------------------
Break Continue Help
---------------------------


It seems strange that you can't reproduce it in D2010
Maybe you'd be careful to make fresh and default (user's not developer's) installations of both the JVCL and sampel project from that bug ?
(0018082)
Arioch (developer)
2010-11-11 02:32

here u have it (4651 exampe) attached pre-compiled

run, click on down-arrow in the Picker, then click on the form background to remove focus from the Picker, see result

---

all in all i consider this bug more important than 4651:
1) this bug occures always while 4651 only in some usecases
2) for 4651 user can easily make learn workaround, so it is only annoying
   with this bug user can do nothing to come around it, it is just broken functionality

PS: all in all i still can't understand, why 4651 was accepted. Crippling another component rather making very same changes in problematic component...
(0018084)
Arioch (developer)
2010-11-11 03:57

i reopened 4651.

My own position is:
  JvDBDateTimePicker is can of worms, in some aspects it tries to outsmart both VCL and Windows itself.
  Problems with it should never be soothed by breaking other components.

This bug is to be fixing by reverting 4651, then thinking what to do.
(0018190)
AHUser (developer)
2010-11-27 22:23

Fixed in svn revision 12914.

The inherited is back and I fixed another NullText bug when the user clicks outside of the popup calendar and Date=NullDate the 1899-12-30 was displayed instead of NullText.

- Issue History
Date Modified Username Field Change
2010-09-18 21:45 tetardd New Issue
2010-09-20 10:47 obones Note Added: 0017685
2010-09-20 10:47 obones Status new => feedback
2010-09-23 13:38 tetardd Note Added: 0017703
2010-09-23 13:46 tetardd Note Added: 0017704
2010-10-08 16:38 obones Relationship added related to 0004651
2010-10-08 16:38 obones Relationship added related to 0005330
2010-10-11 10:37 obones Note Added: 0017867
2010-10-11 10:37 obones Status feedback => acknowledged
2010-11-11 02:11 Arioch Note Added: 0018080
2010-11-11 02:14 Arioch Note Added: 0018081
2010-11-11 02:28 Arioch File Added: DatePicker_BDS-XE.7z
2010-11-11 02:32 Arioch Note Added: 0018082
2010-11-11 03:57 Arioch Note Added: 0018084
2010-11-27 22:23 AHUser Note Added: 0018190
2010-11-27 22:23 AHUser Status acknowledged => resolved
2010-11-27 22:23 AHUser Fixed in Version => Daily / SVN
2010-11-27 22:23 AHUser Resolution open => fixed
2010-11-27 22:23 AHUser Assigned To => AHUser
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker