Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005345 [JEDI VCL] 00 JVCL Components major always 2010-09-30 17:10 2012-02-29 16:53
Reporter SGlienke View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005345: TJvControlsCompareValidator loses CompareToProperty after loading from dfm
Description If you define a TJvControlsCompareValidator during designtime it loses the CompareToProperty value at runtime or when you switch to viewing dfm as text and back.

Reason is a missing "if not (csLoading in ComponentState) then" in line 689 of JvValidators.pas.
Additional Information
Tags No tags attached.
Attached Files zip file icon Issue5345.zip [^] (1,300 bytes) 2010-10-09 14:54

- Relationships

-  Notes
(0017842)
obones (administrator)
2010-10-08 16:40

Please provide the zipped sources of a sample application showing this
(0017850)
SGlienke (reporter)
2010-10-09 14:54

Look at the dfm File. You see that the properties for the TJvControlsCompareValidator are set correctly. When you open the project you notice the value for the property CompareToProperty is empty. Thats because of the missing line in the JvValidators.pas
(0018057)
obones (administrator)
2010-11-09 14:55

I'm seeing it indeed.
If I understand you correctly, the code before the fix looks like this:

    if FCompareToControl <> nil then
    begin
      if Supports(FCompareToControl, IJvValidationProperty, Obj) then
        CompareToProperty := Obj.GetValidationPropertyName
      else
        CompareToProperty := '';
    end;


And with the fix, it looks like this:

    if FCompareToControl <> nil then
    begin
      if not (csLoading in ComponentState) then
        if Supports(FCompareToControl, IJvValidationProperty, Obj) then
          CompareToProperty := Obj.GetValidationPropertyName
        else
          CompareToProperty := '';
    end;

Is that right?
(0018058)
SGlienke (reporter)
2010-11-09 14:56

Exactly
(0018061)
obones (administrator)
2010-11-09 15:12

Thanks, this is now in SVN

- Issue History
Date Modified Username Field Change
2010-09-30 17:10 SGlienke New Issue
2010-10-08 16:40 obones Note Added: 0017842
2010-10-08 16:40 obones Status new => feedback
2010-10-09 14:54 SGlienke File Added: Issue5345.zip
2010-10-09 14:54 SGlienke Note Added: 0017850
2010-11-09 14:55 obones Note Added: 0018057
2010-11-09 14:56 SGlienke Note Added: 0018058
2010-11-09 15:12 obones Note Added: 0018061
2010-11-09 15:12 obones Status feedback => resolved
2010-11-09 15:12 obones Fixed in Version => Daily / SVN
2010-11-09 15:12 obones Resolution open => fixed
2010-11-09 15:12 obones Assigned To => obones
2012-02-29 16:53 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker