Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005374 [JEDI VCL] 00 JVCL Components major always 2010-10-21 18:25 2012-02-29 16:55
Reporter larrye1428 View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005374: JvDataProvider.hpp(116): E2034 Cannot convert '_di_IInterface' to '_GUID' Full parser context Unit1.cpp(6):
Description Using xe c++ builder
new project
drop TJvFullColorCircle on form
compile get:

 [BCC32 Error] JvDataProvider.hpp(116): E2034 Cannot convert '_di_IInterface' to '_GUID'
  Full parser context
    Unit1.cpp(6): #include Unit1.h
    Unit1.h(10): #include C:\jedi\jvcl\include\D15\JvFullColorCtrls.hpp
    JvFullColorCtrls.hpp(29): #include C:\jedi\jvcl\include\D15\JvCombobox.hpp
    JvCombobox.hpp(28): #include C:\jedi\jvcl\include\D15\JvDataProvider.hpp
    JvDataProvider.hpp(31): namespace Jvdataprovider
    JvDataProvider.hpp(71): class TExtensibleInterfacedPersistent
    JvDataProvider.hpp(123): decision to instantiate: operator TExtensibleInterfacedPersistent::_di_IInterface()
    --- Resetting parser context for instantiation...
    JvDataProvider.hpp(114): parsing: operator TExtensibleInterfacedPersistent::_di_IInterface()
Additional Information
Tags No tags attached.
Attached Files zip file icon jvlab.zip [^] (87,679 bytes) 2010-11-09 18:49

- Relationships
has duplicate 0005396resolvedobones JvLabel and JvFullColorLabel are not compatible with the CBuilder XE 

-  Notes
(0018028)
obones (administrator)
2010-11-09 14:14

I'm not able to reproduce this using the latest SVN content.
Please try again with the latest SVN content.
If this is still here, please provide the zipped sources of a sample application showing this.
(0018068)
vez (reporter)
2010-11-09 18:51

I tested on the latest SVN, (9.11.2010), can see this again, see the project.
(0018192)
AHUser (developer)
2010-11-27 23:00

Fixed in svn revision 12915.

- Issue History
Date Modified Username Field Change
2010-10-21 18:25 larrye1428 New Issue
2010-11-09 13:29 obones Relationship added has duplicate 0005396
2010-11-09 14:14 obones Note Added: 0018028
2010-11-09 14:14 obones Status new => feedback
2010-11-09 18:49 vez File Added: jvlab.zip
2010-11-09 18:51 vez Note Added: 0018068
2010-11-27 23:00 AHUser Note Added: 0018192
2010-11-27 23:00 AHUser Status feedback => resolved
2010-11-27 23:00 AHUser Fixed in Version => Daily / SVN
2010-11-27 23:00 AHUser Resolution open => fixed
2010-11-27 23:00 AHUser Assigned To => AHUser
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker