Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005389 [JEDI VCL] 00 JVCL Components major always 2010-11-04 18:21 2012-02-29 16:55
Reporter ZENsan View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005389: JvStrToHtml.HtmlToString do not converts characters { and ሴ
Description JvStrToHtml.HtmlToString do not converts characters { and ሴ

There is workaround for HtmlToString function (maybe some optimization is required):
              // if no conversion was found, it may actually be a number
              if Ch = #0 then
                begin
                  ReplStr := Copy(ReplStr, 2, Length(ReplStr) - 2);
                  if Copy(ReplStr, 1, 1) = '#' then
                    begin
                      Delete(ReplStr, 1, 1);
                      if SameStr(Copy(ReplStr, 1, 1), 'x') then
                        ReplStr[1] := '$';
                    end;
                  if StrToIntDef(ReplStr, -1) <> -1 then
                    Ch := Chr(StrToInt(ReplStr))
                  else
                    begin
                      I := Start;
                      Ch := Value[I];
                    end;
                end;
Additional Information
Tags No tags attached.
Attached Files rar file icon JediHtml.rar [^] (5,398 bytes) 2010-11-09 14:46

- Relationships

-  Notes
(0018001)
outchy (administrator)
2010-11-05 13:03

Shouldn't this issue be moved to the JVCL project? There is nothing related to HTML inside JclStrings.pas from the JCL.
(0018002)
ZENsan (reporter)
2010-11-05 13:05

ops.. Yes, it is for JVCL. Sorry.
(0018037)
obones (administrator)
2010-11-09 14:19

Please provide the zipped sources of a sample application showing this.
(0018055)
ZENsan (reporter)
2010-11-09 14:48

I also uploaded there JvStrToHtml2.pas, which converts HTML perfectly. Because original code misses a lot of entities! And also it loses Unicode characters!
(0018149)
ZENsan (reporter)
2010-11-23 13:40

Any news?
(0018186)
AHUser (developer)
2010-11-27 19:15

Fixed in svn revision 12912.

- Issue History
Date Modified Username Field Change
2010-11-04 18:21 ZENsan New Issue
2010-11-04 18:21 ZENsan IDE version => Delphi/C++Builder XE
2010-11-05 13:03 outchy Note Added: 0018001
2010-11-05 13:05 ZENsan Note Added: 0018002
2010-11-06 11:41 outchy Issue Monitored: outchy
2010-11-06 11:41 outchy Issue End Monitor: outchy
2010-11-06 11:41 outchy Project JEDI Code Library => JEDI VCL
2010-11-06 11:42 outchy Category JclStrings => 00 JVCL Components
2010-11-06 11:42 outchy version Version 2.3 (Subversion repository/Daily zips) => Daily / SVN
2010-11-06 11:42 outchy Summary JvStrToHtml.HtmlToString do not converts characters { and &#x1234; => JvStrToHtml.HtmlToString do not converts characters { and &#x1234;
2010-11-06 11:42 outchy Description Updated
2010-11-09 14:19 obones Note Added: 0018037
2010-11-09 14:19 obones Status new => feedback
2010-11-09 14:46 ZENsan File Added: JediHtml.rar
2010-11-09 14:48 ZENsan Note Added: 0018055
2010-11-23 13:40 ZENsan Note Added: 0018149
2010-11-27 19:15 AHUser Note Added: 0018186
2010-11-27 19:15 AHUser Status feedback => resolved
2010-11-27 19:15 AHUser Fixed in Version => Daily / SVN
2010-11-27 19:15 AHUser Resolution open => fixed
2010-11-27 19:15 AHUser Assigned To => AHUser
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker