Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005419 [JEDI VCL] 00 JVCL Components minor always 2010-11-24 10:49 2012-02-29 16:55
Reporter msm View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005419: TJvDBGrid
Description TJvDBGrid component: fields with editmask defined do not show formatted
!!!
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0005284resolvedAHUser mask in jvdbGrid 

-  Notes
(0018162)
ZENsan (reporter)
2010-11-26 14:43

There is no relation between EditMask and the way how field is displayed. For defining display format user DisplayFormat property of the field instead.
(0018163)
msm (reporter)
2010-11-26 16:36

I consider with an imperfection, since in component standard of delphi2010 (TDBGrid) when has a field with editmask (string) functions perfectly.

P.S.: I am using the Firebird as data base.
(0018164)
msm (reporter)
2010-11-26 17:19

If they had been deceptive therefore does not exist DisplayFormat property for field type string!
(0018169)
jfudickar (developer)
2010-11-27 11:31

Could you try to create a small sample using the tClientdataset
(0018182)
AHUser (developer)
2010-11-27 15:28

Fixed in svn revision 12909.

- Issue History
Date Modified Username Field Change
2010-11-24 10:49 msm New Issue
2010-11-24 10:51 msm Issue Monitored: msm
2010-11-26 14:43 ZENsan Note Added: 0018162
2010-11-26 16:36 msm Note Added: 0018163
2010-11-26 17:19 msm Note Added: 0018164
2010-11-27 11:31 jfudickar Note Added: 0018169
2010-11-27 11:31 jfudickar Status new => feedback
2010-11-27 15:28 AHUser Note Added: 0018182
2010-11-27 15:28 AHUser Status feedback => resolved
2010-11-27 15:28 AHUser Fixed in Version => Daily / SVN
2010-11-27 15:28 AHUser Resolution open => fixed
2010-11-27 15:28 AHUser Assigned To => AHUser
2010-11-28 02:00 AHUser Relationship added duplicate of 0005284
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker