Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005421 [JEDI VCL] 00 JVCL Components major have not tried 2010-11-24 17:38 2012-02-29 16:55
Reporter triline View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005421: TJvCheckTreeView and TJvEmbeddedFormPanel / TJvEmbeddedInstanceFormPanel
Description When you add a TJvCheckTreeView to a from and works with the checkboxes now it works fine when you are don't using a EmbeddedForm.

When you try to add the childform into the EmbeddedForm, then all not checked elements loosing the checkbox attribute.

The same error occurs when u set the Parent of the childform to a panel onside the masterform.
Additional Information
Tags No tags attached.
Attached Files 7z file icon jvTreeViewTest.7z [^] (266,514 bytes) 2010-11-24 17:38

- Relationships

-  Notes
(0018183)
AHUser (developer)
2010-11-27 16:18

Fixed in svn revision 12910 (for TJvEmbeddedFormPanel).

You misunderstood how TJvEmbeddedInstanceFormPanel works. It creates a new instance of the linked form. So the checked nodes are all false because your TForm2 doesn't initialize them to another value.

- Issue History
Date Modified Username Field Change
2010-11-24 17:38 triline New Issue
2010-11-24 17:38 triline File Added: jvTreeViewTest.7z
2010-11-27 16:18 AHUser Note Added: 0018183
2010-11-27 16:18 AHUser Status new => resolved
2010-11-27 16:18 AHUser Fixed in Version => Daily / SVN
2010-11-27 16:18 AHUser Resolution open => fixed
2010-11-27 16:18 AHUser Assigned To => AHUser
2012-02-29 16:55 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker