Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005439 [JEDI VCL] 00 JVCL Components major always 2010-12-11 12:43 2011-09-21 14:10
Reporter tetardd View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005439: 2 serious flaws in TJvStringGrid.AutoSizeCol
Description - TJvStringGrid.AutoSizeCol add 8 to the text width. That should not be hard-coded, what if someone wants another padding value?
- If the canvas has been changed to draw, for example fixed rows (SetCanvasProperties), the calculated text width is wrong. See the example.

A minor issue (just because I was told off for not following the formatting of your code, I just thought I'd report one): unconsistent declaration:
  TJvStringGrid = class(TJvExStringGrid)
  private
    ...
    FSetCanvasProperties: TDrawCellEvent;
    FGetCellAlignment: TGetCellAlignmentEvent;

Should that not be:
  TJvStringGrid = class(TJvExStringGrid)
  private
    FOnSetCanvasProperties: TDrawCellEvent;
    FOnGetCellAlignment: TGetCellAlignmentEvent;
Additional Information
Tags No tags attached.
Attached Files zip file icon Bug jvStringGrid.zip [^] (615,878 bytes) 2010-12-11 12:43

- Relationships

-  Notes
(0018385)
AHUser (developer)
2011-02-16 20:40

Fixed in svn revision 12987.

- Issue History
Date Modified Username Field Change
2010-12-11 12:43 tetardd New Issue
2010-12-11 12:43 tetardd File Added: Bug jvStringGrid.zip
2011-02-15 13:46 obones Status new => acknowledged
2011-02-16 20:40 AHUser Note Added: 0018385
2011-02-16 20:40 AHUser Status acknowledged => resolved
2011-02-16 20:40 AHUser Fixed in Version => Daily / SVN
2011-02-16 20:40 AHUser Resolution open => fixed
2011-02-16 20:40 AHUser Assigned To => AHUser
2011-09-21 14:10 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker