Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005461 [JEDI VCL] 00 JVCL Components major always 2011-01-18 23:24 2012-02-27 16:56
Reporter LarryHengen View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version 3.40
Summary 0005461: If you do not set the PropertyToValidate in a JvCustomValidator the ValueToValidate is NULL
Description When the ValueToValidate = Null in the OnValidate event, assigning it to a string will generate an exception. There should be some sort of validation to ensure all the appropriate properties are set on the validator. The Loaded event could be used to validate the properties and raise and exception to report the cause rather than have the symptom later result in an error.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0018352)
obones (administrator)
2011-02-15 13:48

Please provide the zipped sources of a sample application showing this.
(0018593)
obones (administrator)
2011-06-07 17:37

any news?
(0019594)
obones (administrator)
2012-02-27 16:56

No news, not able to reproduce

- Issue History
Date Modified Username Field Change
2011-01-18 23:24 LarryHengen New Issue
2011-02-15 13:48 obones Note Added: 0018352
2011-02-15 13:48 obones Status new => feedback
2011-06-07 17:37 obones Note Added: 0018593
2012-02-27 16:56 obones Note Added: 0019594
2012-02-27 16:56 obones Status feedback => resolved
2012-02-27 16:56 obones Resolution open => unable to reproduce
2012-02-27 16:56 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker