Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005486 [JEDI VCL] 00 JVCL Components crash always 2011-02-17 10:11 2011-09-21 14:10
Reporter ZENsan View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005486: function CompareRecord in JvDBUtils wasn't fixed right way.
Description I provided source file just to demonstrate the appeareance. But really it must be somethuing like this. Because KeyValues not always is array...

  function CompareRecord: Boolean;
  var
    I: Integer;
  begin
    Result := True;
    if VarIsArray(KeyValues) then
      for I := 0 to FieldCount - 1 do
      begin
        Fld := TField(Fields[I]);
        Result := Result and CompareField(Fld, KeyValues[I]);
      end
    else
      if FieldCount > 0 then
        begin
          Fld := TField(Fields.First);
          Result := CompareField(Fld, KeyValues);
        end;
  end;
Additional Information It's about bug ID 0005485
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0018386)
AHUser (developer)
2011-02-17 19:14

Fixed in svn revision 12988.

- Issue History
Date Modified Username Field Change
2011-02-17 10:11 ZENsan New Issue
2011-02-17 19:14 AHUser Note Added: 0018386
2011-02-17 19:14 AHUser Status new => resolved
2011-02-17 19:14 AHUser Fixed in Version => Daily / SVN
2011-02-17 19:14 AHUser Resolution open => fixed
2011-02-17 19:14 AHUser Assigned To => AHUser
2011-09-21 14:10 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker