Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005518 [JEDI VCL] 00 JVCL Components minor always 2011-03-23 18:42 2011-09-21 14:10
Reporter SGlienke View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005518: TJvWizardRouteMapSteps - ShowNavigators not considered in DetectPage method
Description Clicking at the position of the navigator arrows changes the pages even if the ShowNavigators property is False and the arrows are actually not painted.
Additional Information Fixed like follows:

function TJvWizardRouteMapSteps.DetectPage(const Pt: TPoint): TJvWizardCustomPage;
begin
  if FShowNavigators then
  begin
    // Ignore all disabled pages at run time.
    if PtInRect(GetPreviousArrowRect, Pt) then
    begin
      if (PageIndex < Wizard.PageCount) and (PageIndex > 0) and
        not ((csDesigning in ComponentState) or (bkBack in Wizard.WizardPages[PageIndex].EnabledButtons)) then
        Result := nil
      else
        Result := Wizard.FindNextPage(PageIndex, -1, not (csDesigning in ComponentState));
    end
    else
      if PtInRect(GetNextArrowRect, Pt) then
      begin
        if (PageIndex < Wizard.PageCount) and (PageIndex > 0) and
          not ((csDesigning in ComponentState) or (bkNext in Wizard.WizardPages[PageIndex].EnabledButtons)) then
          Result := nil
        else
          Result := Wizard.FindNextPage(PageIndex, 1, not (csDesigning in ComponentState));
      end
      else
        Result := nil;
  end
  else
    Result := nil;
end;
Tags No tags attached.
Attached Files zip file icon Project1.zip [^] (3,529 bytes) 2011-06-08 07:46

- Relationships

-  Notes
(0018478)
debose (reporter)
2011-03-30 10:18

Yes, I ran into that bug with disabled navigator buttons yesterday.

Also there is another "issue" with that navigators. Clicking that, does not triggers events OnNextButtonClick, OnPreviousButtonClick. But it should, I suppose.
(0018480)
SGlienke (reporter)
2011-03-30 10:40

@debose: That issue has been discussed here:
http://issuetracker.delphi-jedi.org/view.php?id=1629 [^]

Imo the navigator buttons should not fire the On...ButtonClick because actually you did not click the Buttons. Like Andreas (AHUser) mentioned in the other issue you should put code that needs to be triggered when changing pages into the OnSelectNextPage and OnSelectPriorPage events.
(0018481)
debose (reporter)
2011-03-30 11:08

@SGlienke
Thank you very much. I didn't know about events OnSelectNextPage, OnSelectNextPage.
(0018614)
obones (administrator)
2011-06-07 17:49

Please provide the zipped sources of a sample application showing this
(0018646)
FBiehn (reporter)
2011-06-08 07:47

Added a sample application source, if you click on the "N" of "Next Step" or the "B" of "Back to", you change the page
(0018693)
obones (administrator)
2011-06-08 16:30

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2011-03-23 18:42 SGlienke New Issue
2011-03-24 11:20 FBiehn Issue Monitored: FBiehn
2011-03-30 10:18 debose Note Added: 0018478
2011-03-30 10:40 SGlienke Note Added: 0018480
2011-03-30 11:08 debose Note Added: 0018481
2011-06-07 17:49 obones Note Added: 0018614
2011-06-07 17:49 obones Status new => feedback
2011-06-08 07:46 FBiehn File Added: Project1.zip
2011-06-08 07:47 FBiehn Note Added: 0018646
2011-06-08 10:12 obones Status feedback => acknowledged
2011-06-08 16:30 obones Note Added: 0018693
2011-06-08 16:30 obones Status acknowledged => resolved
2011-06-08 16:30 obones Fixed in Version => Daily / SVN
2011-06-08 16:30 obones Resolution open => fixed
2011-06-08 16:30 obones Assigned To => obones
2011-09-21 14:10 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker