Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005537 [JEDI VCL] 00 JVCL Components crash always 2011-03-31 10:56 2011-09-21 14:10
Reporter ZENsan View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005537: JvDebugHandler crashes the Delphi XE IDE
Description JvDebugHandler crashes the Delphi XE IDE.

Open attached sample application. And now try to change Button1 name to "abd & abc".

IDE will crash because FileOpen error to the file which is set in "FileName" property of JvDebugHandler. It must not handle any exception while it is in design time!
Additional Information
Tags No tags attached.
Attached Files zip file icon JEDI.zip [^] (1,150 bytes) 2011-03-31 10:56
? file icon JvDebugHandler.pas [^] (14,150 bytes) 2011-04-20 15:55
? file icon Patch.diff [^] (695 bytes) 2011-04-20 15:56
png file icon Crash.png [^] (165,515 bytes) 2011-06-09 08:04

- Relationships
related to 0005527resolvedobones JvDebugHandler with UnhadledExceptionsOnly do not call default exception handler 

-  Notes
(0018491)
ZENsan (reporter)
2011-03-31 11:02

Tested with current SVN version with full recompilation of all the packages.
(0018501)
ZENsan (reporter)
2011-04-01 13:53

?
(0018524)
ZENsan (reporter)
2011-04-19 10:57

Any news? it really becomes annoying restarting the ide..
(0018526)
ZENsan (reporter)
2011-04-20 15:56

Patch fixes the issue.
(0018681)
obones (administrator)
2011-06-08 15:49

I am unable to reproduce this with the latest SVN content
(0018704)
ZENsan (reporter)
2011-06-09 07:59

Just look at patch file in issue 0005527 (the changes explains them themselves).
(0018705)
ZENsan (reporter)
2011-06-09 08:05

Picture shows You how it happens with latest SVN version. I am not a computer Administrative user. Of course it will work when you develop under Administrator account, but I do not.
(0018707)
obones (administrator)
2011-06-09 09:58

Ah, that was the crucial part missing: "not an administrator".
That would make sense indeed.
(0018710)
ZENsan (reporter)
2011-06-09 10:30

:)
(0018719)
obones (administrator)
2011-06-10 15:03

Wouldn't it be easier to add "and not (csDesigning in ComponentState)" at line 253 inside TJvDebugHandler.ExceptionNotifier?
(0018721)
ZENsan (reporter)
2011-06-10 15:08

Yes.. I just showed the place. I just solved that temporary that way. Yes, your suggestion is right I think.
(0018724)
obones (administrator)
2011-06-10 16:03

This is now in SVN

- Issue History
Date Modified Username Field Change
2011-03-31 10:56 ZENsan New Issue
2011-03-31 10:56 ZENsan File Added: JEDI.zip
2011-03-31 11:02 ZENsan Note Added: 0018491
2011-04-01 13:53 ZENsan Note Added: 0018501
2011-04-19 10:57 ZENsan Note Added: 0018524
2011-04-20 15:55 ZENsan File Added: JvDebugHandler.pas
2011-04-20 15:56 ZENsan File Added: Patch.diff
2011-04-20 15:56 ZENsan Note Added: 0018526
2011-06-07 17:54 obones Status new => acknowledged
2011-06-07 17:55 obones Relationship added related to 0005527
2011-06-08 15:49 obones Note Added: 0018681
2011-06-08 15:49 obones Status acknowledged => feedback
2011-06-09 07:59 ZENsan Note Added: 0018704
2011-06-09 08:04 ZENsan File Added: Crash.png
2011-06-09 08:05 ZENsan Note Added: 0018705
2011-06-09 09:58 obones Note Added: 0018707
2011-06-09 09:59 obones Status feedback => acknowledged
2011-06-09 10:30 ZENsan Note Added: 0018710
2011-06-10 15:03 obones Note Added: 0018719
2011-06-10 15:03 obones Status acknowledged => feedback
2011-06-10 15:08 ZENsan Note Added: 0018721
2011-06-10 16:03 obones Note Added: 0018724
2011-06-10 16:03 obones Status feedback => resolved
2011-06-10 16:03 obones Fixed in Version => Daily / SVN
2011-06-10 16:03 obones Resolution open => fixed
2011-06-10 16:03 obones Assigned To => obones
2011-09-21 14:10 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker