Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005544 [JEDI VCL] 00 JVCL Components crash always 2011-04-05 08:08 2012-09-10 14:15
Reporter korecek View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005544: JvDockSupportControl.pas, BCB6 (D6), Docking and Access Violation (AV)
Description I found out problem which is related to BCB6 and D6 in all probability (I don't know whether D6 do this as well).

I have problem with dockable forms:
1. If I want to move non-docked form on my screen it shows an AV
   (Access Violation) message. No docking is required here.
2. If I want to undock actually docked form (to be floating) it also
   shows the AV message.

I decided to compare older versions of the
JvDockSupportControl.pas and I found there difference in
a "DoFloatForm(Control: TControl)" procedure which is inserted
into a "DragDone(Drop: Boolean)" procedure where is called a
"DragObject.AlphaBlendedForm.Hide" procedure.

I decided to disable this line for BCB6 in the end.
See conditional compilation example below.
When I done it the Float Form AV disappeared.

Conditional compilation :
...
{$IFDEF COMPILER7_UP}
        DragObject.AlphaBlendedForm.Hide;
{$ENDIF !COMPILER7_UP}

Additional Information Example is not need because standard JVCL example named "DockOptionDemo" which is also translated to C++ generates AV as well.

I also checked "DockOptionDemo" under BDS2006 (C++ and Delphi) and under
RAD Studio 2010 as well and there is not such strange behaviour of the demo.

This problem is related to issue:
  http://issuetracker.delphi-jedi.org/view.php?id=5297 [^]
which sold "JvDocking Floating form not drawing correctly " but the
BCB6 was not tested in all probability. ;-)
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019892)
obones (administrator)
2012-06-12 10:04

Confirmed in C6 only
(0019893)
obones (administrator)
2012-06-12 10:10

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2011-04-05 08:08 korecek New Issue
2011-06-07 17:51 obones Status new => acknowledged
2012-06-12 10:04 obones Note Added: 0019892
2012-06-12 10:04 obones Status acknowledged => confirmed
2012-06-12 10:10 obones Note Added: 0019893
2012-06-12 10:10 obones Status confirmed => resolved
2012-06-12 10:10 obones Fixed in Version => Daily / SVN
2012-06-12 10:10 obones Resolution open => fixed
2012-06-12 10:10 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker