Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005565 [JEDI VCL] 00 JVCL Components major always 2011-05-03 14:37 2011-09-21 14:10
Reporter tanffn View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.39
Summary 0005565: Rendering speed problem with TJvXPBar on Win7
Description I am noticing an horribly slow rendering of simple components when they are placed with in a TJvXPBar, I am unable to pinpoint the cause. By slow I mean so slow its hard to resize the window...

I've attached a small test program that demonstrates the problem, simply resize the form (even within the IDE). To "resolve it" you can collapse the JvXPBar.

Additional Information I am using JVCL 3.39, Windows 7 64bit, Delphi 2010.
On Windows XP there isn't such a problem.
Tags No tags attached.
Attached Files zip file icon RenderingSpeedProblem.zip [^] (2,778 bytes) 2011-05-03 14:37

- Relationships

-  Notes
(0018682)
obones (administrator)
2011-06-08 16:00

I am unable to reproduce using Delphi XE, the latest SVN content under Windows 7 x64
(0018730)
AHUser (developer)
2011-06-11 00:58

Fixed in svn revision 13056.

- Issue History
Date Modified Username Field Change
2011-05-03 14:37 tanffn New Issue
2011-05-03 14:37 tanffn File Added: RenderingSpeedProblem.zip
2011-06-07 17:56 obones Status new => acknowledged
2011-06-08 16:00 obones Note Added: 0018682
2011-06-08 16:00 obones Status acknowledged => feedback
2011-06-11 00:58 AHUser Note Added: 0018730
2011-06-11 00:58 AHUser Status feedback => resolved
2011-06-11 00:58 AHUser Fixed in Version => Daily / SVN
2011-06-11 00:58 AHUser Resolution open => fixed
2011-06-11 00:58 AHUser Assigned To => AHUser
2011-09-21 14:10 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker