Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005575 [JEDI VCL] 00 JVCL Components minor always 2011-05-07 01:18 2011-09-21 14:10
Reporter Steve009 View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0005575: TImgBtn memory leak (reported by FastMM4)
Description JVCL version build: JVCL3-2008-10-20 (built with theme enabled)
IDE: BCB6

FastMM4 reports a memory leak for each TJvImgBtn in the project.

Searching the issue tracker doesn't seem to show this issue being previously raised hence I haven't installed the very latest version of JVCL.
Since TImgBtn can use the TImageList it is a very useful button.
Is the leak a bug as such, if so could it (or has it) been fixed.

Many thanks for a great set of controls.

Steve Cann.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0018540)
AHUser (developer)
2011-05-07 13:59

There was no commit to svn related to a memory leak for TJvImgBtn.

What leaks in TJvImgBtn? FastMM should give the the class name (or "unknown").
(0018541)
Steve009 (reporter)
2011-05-08 13:49

Humble appologies because I passed on the wrong information - the leak is with TJvTransparentButtonImages not TImgBtn. I think this leak has already been fixed.
(0018600)
obones (administrator)
2011-06-07 17:42

any news?
(0018743)
AHUser (developer)
2011-06-11 13:08

The bug was fixed in svn revision 12277.

- Issue History
Date Modified Username Field Change
2011-05-07 01:18 Steve009 New Issue
2011-05-07 13:59 AHUser Note Added: 0018540
2011-05-07 13:59 AHUser Assigned To => AHUser
2011-05-07 13:59 AHUser Status new => feedback
2011-05-08 13:49 Steve009 Note Added: 0018541
2011-06-07 17:42 obones Note Added: 0018600
2011-06-11 13:08 AHUser Note Added: 0018743
2011-06-11 13:08 AHUser Status feedback => resolved
2011-06-11 13:08 AHUser Fixed in Version => Daily / SVN
2011-06-11 13:08 AHUser Resolution open => fixed
2011-09-21 14:10 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker