Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005598 [JEDI VCL] 02 Installation major always 2011-06-16 10:23 2012-09-10 14:15
Reporter Gerold View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005598: D6 Installation fails with JVCLThemesEnabled in JvExplorerBarItems
Description Cannot install latest JVCL under Delphi 6 with "XP Theming" enabled in the JVCL 3.41 installer.

In JvExplorerBarItems.pas I found:

...
implementation

uses
  {$IFDEF JVCLThemesEnabled}
  Themes,
  {$ENDIF JVCLThemesEnabled}
  Math, DateUtils;
...

There exists no "Themes.pas" in Delphi 6.

Guess it should be:

  {$IFDEF JVCLThemesEnabled}
  {$IFDEF COMPILER7_UP}
  Themes,
  {$ELSE}
  ThemeSrv,
  {$ENDIF COMPILER7_UP}
  {$ENDIF JVCLThemesEnabled}
  Math, DateUtils;

or

  {$IFDEF JVCLThemesEnabled}
  {$IFDEF COMPILER7_UP}
  Themes,
  {$ENDIF COMPILER7_UP}
  {$ENDIF JVCLThemesEnabled}
  Math, DateUtils;

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0018787)
obones (administrator)
2011-06-20 11:47

The readme.htm file says that if you want theming for D6, you MUST install Mike Lischke's ThemeManager package.
Have you done so?
(0018788)
Gerold (reporter)
2011-06-20 12:09

Yes of course. As I said before, there exists no "Themes.pas" in my D6 ENT or in Mike Lischke's Thememanger.

You can find the objects etc. defined in "Themes.pas" from D7 (or higher???) in "ThemeSrv.pas" from ML's ThemeManager. So I think the units definied between
{$IFDEF JVCLThemesEnabled} and {$ENDIF JVCLThemesEnabled} must be changed for D6.

BTW:
I dont use "XP Theming" in D6 anymore. It was just a test, but maybe other users will have the same problem.
(0018922)
obones (administrator)
2011-09-21 11:47

Need to test with D6 + Theming
(0019058)
AMarchant (reporter)
2011-10-28 03:18

Hi: just to confirm that this issue still exists as of revision 13104 (Delphi 6) - but I think the source has shifted - although the error I'm getting:

"C:\Program Files\Borland\Delphi6\Source\3rdParty\JEDI\JVCL\run\JvExplorerBarItems.pas(398) Fatal: File not found: 'Themes.dcu'"

...isn't entirely consistent with that I think is the cause. JvExplorerBarItems.pas "uses" JvExplorerBar.pas, and like JvExplorerBar of old, it contains:

{$IFDEF JVCLThemesEnabled}
Themes,
{$ENDIF JVCLThemesEnabled}

...in its uses clause. Perhaps, as the OP suggested before, this should conditionally be ThemeSrv for <= Delphi6 with ThemeManager installed?
(0019059)
AMarchant (reporter)
2011-10-28 03:27

Update: sorry, my mistake, I mis-read the first message - it's very late and I've been trying to get around these little niggly issues for hours.

The installer reports the error quoted in my last message, it doesn't involve JvExplorerBar.pas, I'm not sure how I managed to muddle that up - the problem is with JvExplorerBarItems.pas, and its "uses" of "Themes", which matches no named unit in the standalone version of ThemeManager for Delphi 4-6.
(0019060)
AMarchant (reporter)
2011-10-28 16:52

With the benefit of a less sleep addled-mind, I modified JvExplorerBarItems.pas, switching:

397 {$IFDEF JVCLThemesEnabled}
398 Themes,
399 {$ENDIF JVCLThemesEnabled}

to

397 {$IFDEF JVCLThemesEnabled}
398 JvThemes,
399 {$ENDIF JVCLThemesEnabled}

...to match all other controls, and it then compiled without error.
(0019065)
jfudickar (developer)
2011-10-28 22:03

Changed in SVN.

Please retest
(0019067)
AMarchant (reporter)
2011-10-29 15:05

Tested - that compiles without error now, thank you.
(0019068)
grubste (reporter)
2011-10-29 20:06

That change does not compile with Delphi XE2 now.
I had to change JvThemes to Themes again.
(0019079)
AHUser (developer)
2011-11-02 21:10

XE2 compilation is restored.

- Issue History
Date Modified Username Field Change
2011-06-16 10:23 Gerold New Issue
2011-06-20 11:47 obones Note Added: 0018787
2011-06-20 11:47 obones Status new => feedback
2011-06-20 12:09 Gerold Note Added: 0018788
2011-09-21 11:47 obones Note Added: 0018922
2011-09-21 11:47 obones Status feedback => new
2011-09-21 14:15 obones Status new => acknowledged
2011-10-28 03:18 AMarchant Note Added: 0019058
2011-10-28 03:27 AMarchant Note Added: 0019059
2011-10-28 16:52 AMarchant Note Added: 0019060
2011-10-28 22:03 jfudickar Note Added: 0019065
2011-10-28 22:03 jfudickar Status acknowledged => feedback
2011-10-29 15:05 AMarchant Note Added: 0019067
2011-10-29 20:06 grubste Note Added: 0019068
2011-10-29 20:07 grubste Issue Monitored: grubste
2011-11-02 21:10 AHUser Note Added: 0019079
2011-11-02 21:10 AHUser Status feedback => resolved
2011-11-02 21:10 AHUser Fixed in Version => Daily / SVN
2011-11-02 21:10 AHUser Resolution open => fixed
2011-11-02 21:10 AHUser Assigned To => AHUser
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46
2013-05-25 21:04 grubste Issue End Monitor: grubste


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker