Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005601 [JEDI VCL] 00 JVCL Components feature always 2011-06-18 10:13 2012-09-10 14:15
Reporter stevegr View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005601: TJvDBUltimGrid -> Sort TClientDataSet
Description When I tried to sort a TClientDataSet I realised that the only way was to use SortWith:=sfUserFunc and the OnUserSort event. So I contribute a piece of code.

Source Code for Sorting TClientDataSet.
Search for swClient to find the new lines of code.
Additional Information
Tags No tags attached.
Attached Files ? file icon JvDBUltimGrid.pas [^] (25,311 bytes) 2011-06-18 10:13
? file icon JvDBUltimGrid_2011-06-19.pas [^] (24,643 bytes) 2011-06-19 17:41
? file icon JvDBGrid.pas [^] (160,445 bytes) 2011-06-20 19:39
? file icon JvDBUltimGrid_2011-06-20.pas [^] (24,689 bytes) 2011-06-20 19:42

- Relationships

-  Notes
(0018780)
jfudickar (developer)
2011-06-19 15:50

Closed by mistake
(0018783)
stevegr (reporter)
2011-06-19 18:06

Sometimes after sorting is usefull not to change to position of the current record, so I contribute an update of the TJvDBUltimGrid unit.

Note: Adding property FRestoreOnSort: Boolean;
(0018792)
stevegr (reporter)
2011-06-20 19:38

Updated code: Replace unit with the new one.
(0018793)
stevegr (reporter)
2011-06-20 19:55

There a thing though.
Sorting column is triggered by both Click and DoubleClick on title.
Double clicking on title should NOT trigger sorting because it fires its own user event and is not a good idea to happen both at the same time. That I could not fix so far.
(0018794)
jfudickar (developer)
2011-06-20 20:35

Could you please create a separate bug report for the DoubleClick sorting problem.
Regards
Jens
(0018923)
obones (administrator)
2011-09-21 11:47

What's the status here?
(0019496)
obones (administrator)
2012-02-23 10:59

Any news ? I'm very tempted to "resolve" this issue as "nothing to change"
(0019515)
stevegr (reporter)
2012-02-23 12:50

You can easily "close" this issue on my behalf, regarding TJvDBUltimGrid the source code with new features and bug fixes will be contributed to a new report soon.
(0019516)
obones (administrator)
2012-02-23 13:36

Thanks for the confirmation

- Issue History
Date Modified Username Field Change
2011-06-18 10:13 stevegr New Issue
2011-06-18 10:13 stevegr File Added: JvDBUltimGrid.pas
2011-06-18 21:06 jfudickar Status new => resolved
2011-06-18 21:06 jfudickar Resolution open => fixed
2011-06-18 21:06 jfudickar Assigned To => jfudickar
2011-06-19 15:50 jfudickar Note Added: 0018780
2011-06-19 15:50 jfudickar Status resolved => feedback
2011-06-19 15:50 jfudickar Resolution fixed => reopened
2011-06-19 17:41 stevegr File Added: JvDBUltimGrid_2011-06-19.pas
2011-06-19 18:06 stevegr Note Added: 0018783
2011-06-20 19:38 stevegr Note Added: 0018792
2011-06-20 19:39 stevegr File Added: JvDBGrid.pas
2011-06-20 19:42 stevegr File Added: JvDBUltimGrid_2011-06-20.pas
2011-06-20 19:55 stevegr Note Added: 0018793
2011-06-20 20:35 jfudickar Note Added: 0018794
2011-09-21 11:47 obones Note Added: 0018923
2012-02-23 10:59 obones Note Added: 0019496
2012-02-23 12:50 stevegr Note Added: 0019515
2012-02-23 13:36 obones Note Added: 0019516
2012-02-23 13:36 obones Status feedback => resolved
2012-02-23 13:36 obones Fixed in Version => Daily / SVN
2012-02-23 13:36 obones Resolution reopened => fixed
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker