Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005610 [JEDI VCL] 00 JVCL Components minor always 2011-06-26 19:16 2012-09-10 14:15
Reporter stevegr View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005610: TJvDBGrids, Vertical seperator line on title cells is not displayed.
Description Vertical seperator line on title cells is not displayed when DrawingStyle is gdsThemed on Windows 7.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0005662confirmed JvDBGrids.FixedCols 
related to 0005806resolvedobones JvDBGrid - DefaultDrawColumnCell and ShowMemos 

-  Notes
(0018929)
obones (administrator)
2011-09-21 11:49

Please provide the zipped sources of a sample application showing this
(0018987)
stevegr (reporter)
2011-09-27 11:03

Demo application: Mantis 5662.
(0019564)
obones (administrator)
2012-02-27 11:15

I'm not seeing this using demo from 0005806 under Win7 and Delphi XE
(0019579)
stevegr (reporter)
2012-02-27 13:38

Demo is compiled with Delphi 2010 under win7 and tested on win7 and XP platforms.
(0019616)
obones (administrator)
2012-02-28 17:14

I seriously believe this is already fixed with the current SVN content.
(0019618)
stevegr (reporter)
2012-02-28 19:07

I tested current SVN (JVCL3-Source-2012-02-28), compiled demo but nothing is changed since the last demo:

Only at run-time (style gdsThemed), vertical seperator line on title cells not displayed. At design-time is ok. Hard to believe that's a problem of Delphi 2010.
If you could give me a hint where to look into code, I could give it a try to help.
(0019626)
obones (administrator)
2012-02-29 14:35

I'm serious, I'm seeing them with gdsThemed
However, it's with gdsGradient that I'm not seeing them, could it be that you mixed the two modes?
(0019628)
stevegr (reporter)
2012-02-29 16:14

Issue is resolved for all three styles. For new grids placed on the form work ok, the problem remains for the already existed grids. That tells me that is not a bug of the component any more. Issue resolved.

Regards,
Steve
(0019630)
obones (administrator)
2012-02-29 16:48

Ok, thanks for letting us know

- Issue History
Date Modified Username Field Change
2011-06-26 19:16 stevegr New Issue
2011-09-21 11:49 obones Note Added: 0018929
2011-09-21 11:49 obones Status new => feedback
2011-09-27 11:03 stevegr Note Added: 0018987
2011-10-07 16:12 obones Relationship added related to 0005662
2011-10-07 16:12 obones Status feedback => acknowledged
2012-02-27 11:15 obones Relationship added related to 0005806
2012-02-27 11:15 obones Note Added: 0019564
2012-02-27 11:15 obones Status acknowledged => feedback
2012-02-27 13:38 stevegr Note Added: 0019579
2012-02-28 17:14 obones Note Added: 0019616
2012-02-28 19:07 stevegr Note Added: 0019618
2012-02-29 14:35 obones Note Added: 0019626
2012-02-29 16:14 stevegr Note Added: 0019628
2012-02-29 16:48 obones Note Added: 0019630
2012-02-29 16:48 obones Status feedback => resolved
2012-02-29 16:48 obones Fixed in Version => Daily / SVN
2012-02-29 16:48 obones Resolution open => fixed
2012-02-29 16:48 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker