Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005651 [JEDI VCL] 02 Installation block always 2011-09-11 19:46 2011-09-21 14:13
Reporter PeterPanino View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version Daily / GIT
Summary 0005651: JVCL 3.45 cannot be installed in Delphi XE2
Description Version is 3.45 (see here: http://cc.embarcadero.com/item/28421 [^] )

I tried to install JVCL in DelphiXE2. Here is the outcome:

0. JCL of course was already installed in Delphi XE2.
1. Run install.bat: No problems.
2. Run the installer: Worked fine, no errors.
3. Run Delphi XE2: When the DelphiXE2 splash screen was displayed, the following error message was displayed, for each JVCL package accordingly:

http://img204.imageshack.us/img204/916/errorzj.gif [^]

which translated to English means:

Package C:\Users\Public\Documents\RAD Studio\9.0\Bpl\JvAppFrmDesignl60.bpl cannot be loaded.
%1 is not a valid Win32-application.

But the JvAppFrmDesignl60.bpl DOES exist in the above path, and also the other JVCL BPLs.

I tried to install single JVCL packages manually, they could be built and compiled but not installed.

So why JVCL 3.45 cannot be installed in DelphiXE2?

Additional Information My system: Windows 7 64bit
Tags No tags attached.
Attached Files gif file icon error.gif [^] (16,341 bytes) 2011-09-11 19:46

- Relationships

-  Notes
(0018896)
outchy (administrator)
2011-09-19 15:32

make sure that the BPL output path is in the "PATH" environment variable.
(0018901)
RHoek (reporter)
2011-09-20 16:33

I've installed the latest SVN version and didn't have these problems.
- NOTE: I only installed the 32-bit version
(0018954)
obones (administrator)
2011-09-21 14:13

Unable to reproduce

- Issue History
Date Modified Username Field Change
2011-09-11 19:46 PeterPanino New Issue
2011-09-11 19:46 PeterPanino File Added: error.gif
2011-09-11 20:07 PeterPanino Issue Monitored: PeterPanino
2011-09-19 15:32 outchy Note Added: 0018896
2011-09-20 16:31 RHoek Issue Monitored: RHoek
2011-09-20 16:33 RHoek Note Added: 0018901
2011-09-21 14:13 obones Note Added: 0018954
2011-09-21 14:13 obones Status new => resolved
2011-09-21 14:13 obones Resolution open => unable to reproduce
2011-09-21 14:13 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker