Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005681 [JEDI VCL] 02 Installation major always 2011-10-13 19:30 2011-10-16 21:58
Reporter jkelley View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.45
Summary 0005681: Can't load package JvNetDesign160.bpl
Description I downloaded JVCL 3.45 from the Subversion repository, enabled USE_3RDPARTY_INDY and USE_3RDPARTY_INDY10, and installed it for RAD Studio 2010 and XE2. However, whenever I run RAD Studio XE2, I get the following errors:

Can't load package C:\Users\Public\Documents\RAD Studio\9.0\Bpl\JvNetDesign160.bpl.
Cannot load package 'JvNet160.' It contains unit 'IdCookie', which is also contained in package 'IndyProtocols160'.
Do you want to attempt to load this package the next time a project is loaded?

RAD Studio 2010 and earlier versions work fine. It seems as though the installer isn't recognizing that USE_3RDPARTY_INDY and USE_3RDPARTY_INDY10 are enabled when it uses JvNet-R.xml to create packages\d16\JvNet.dpk.

I also noticed that, when I re-run the JVCL installer, it doesn't remember that USE_3RDPARTY_INDY and USE_3RDPARTY_INDY10 are enabled for XE2. (It does remember these settings for 2010 and earlier versions.) This might be related.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019028)
jfudickar (developer)
2011-10-16 21:10

The problem seems to be that the condition d16 is not recogniced.

Same with other packages like odac or devexpress
(0019029)
jfudickar (developer)
2011-10-16 21:58

Hopefully fixed now in the SVN repository.
It was a problem of the jvcld16win32.inc filename. This was not compatible
with pg.exe the package generator.

Please check the new version.

Regards
Jens

- Issue History
Date Modified Username Field Change
2011-10-13 19:30 jkelley New Issue
2011-10-16 21:10 jfudickar Note Added: 0019028
2011-10-16 21:57 jfudickar Status new => acknowledged
2011-10-16 21:58 jfudickar Note Added: 0019029
2011-10-16 21:58 jfudickar Status acknowledged => resolved
2011-10-16 21:58 jfudickar Resolution open => fixed
2011-10-16 21:58 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker