Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005688 [JEDI VCL] 00 JVCL Components crash always 2011-10-19 12:21 2012-09-10 14:15
Reporter Arioch View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005688: no Jv Get Text on 64-bit Windows
Description Delphi XE2 Upd1

jvcld16win64.inc - it should never have {$DEFINE USE_DXGETTEXT}

Neiter original library (last update in 2010) - http://svn.berlios.de/wsvn/dxgettext/trunk/dxgettext/sample/gnugettext.pas [^]
Nor JVCL old fork - JvGnuGetText.pas

None of them allows THook.Create on Win64

So - it should be disabled for all platforms other than Win32.
Otherwise JvComponent and JvComponentBase fail initialization in Win64 exe's.

And BTW, why keeping forked GetText ? Why at all it had to eb forked and why not go back to upstream optionally ?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019436)
obones (administrator)
2012-02-22 14:39

It needed to be forked so that the unit name is different.
As to THook, yes it needs to be looked at, I believe it's only a matter of making it use more bytes because of longer address field.
(0019479)
Arioch (developer)
2012-02-22 21:48

why it had to be different ?
i see only one reason - to allow fork.

So i think it was the opposite, for some obscure reason JVCL decided to fork it, and that enforced files renaming.

Maybe that was somethign about D5 compatibility, i remember original Dx project itself had forks for D5 and for later versions.

Anyway, upstream is seemingly dead and i feel like JVCL has to decide either to maintain GetText or to completely clean it out of JVCL.


// Also i got an impression that {$DEFINE USE_DXGETTEXT} switch enables JvGetText not the vanilla upstream usage, which was itself confusing.
Though i am not sure about latter point now, was too far ago to remember exactly. //
(0019483)
obones (administrator)
2012-02-23 09:11

Upstream is not dead, it's just that you don't know where to look.
I even made some changes a month ago, that were discussed in the dxgettext group.
Thing is, not many people have comitted to their repository, but it continues to evolve.
The current problem is that x64 support is broken because I don't have the opportunity to test for it. This will changed in the upcoming months, but until then, I can't do much more
(0019905)
obones (administrator)
2012-06-12 12:13

Synchronized with upstream version

- Issue History
Date Modified Username Field Change
2011-10-19 12:21 Arioch New Issue
2012-01-11 17:57 elsdoerfer Issue Monitored: elsdoerfer
2012-02-22 14:39 obones Note Added: 0019436
2012-02-22 14:39 obones Status new => acknowledged
2012-02-22 21:48 Arioch Note Added: 0019479
2012-02-23 09:11 obones Note Added: 0019483
2012-06-12 12:13 obones Note Added: 0019905
2012-06-12 12:13 obones Status acknowledged => resolved
2012-06-12 12:13 obones Fixed in Version => Daily / SVN
2012-06-12 12:13 obones Resolution open => fixed
2012-06-12 12:13 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker