Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005717 [JEDI VCL] 00 JVCL Components major always 2011-11-21 21:02 2012-09-10 14:15
Reporter eje92 View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005717: TJvIPAddress Causes Crash as Win64 Application Closes
Description If the user types at a TJvIPAddress control in a Win64 Delphi XE2 application, the program later raises an Access Violation exception as it closes. This will not happen if the form simply contains a TJvIPAddress control but the user does not type into it (or types hardly anything). It happens only when the application is compiled as a Win64 application; Win32 applications never exhibit the bug. The crash can be seen as the program closes while running in the integrated debugger. When running the compiled program directly, Windows 7 reports an error as the program closes. The crash can be reproduced most of the time when typing an address of 192.168.168.17.
Additional Information I originally reported this as Issue 0005714 on November 16, 2011. That issue was marked “Revolved” on November 19, 2011 with the comment “Fixed with revision 13173.” I installed the November 21, 2011 daily download of the JVCL and installed it into Delphi XE2. After rebuilding the application, the problem still exists. Sample code has been attached this time.
Tags No tags attached.
Attached Files zip file icon TJvIPAddressDemo.ZIP [^] (82,059 bytes) 2011-11-21 21:02

- Relationships

-  Notes
(0019121)
AHUser (developer)
2011-11-22 20:09

I can't reproduce this with the svn head.

Can you confirm that the "TJvIPEditControlHelper.SetHandle" method contains the line "FOrgWndProc := Pointer(SetWindowLongPtr(FHandle, GWL_WNDPROC, LONG_PTR(FInstance)));" (line 805)
(0019128)
eje91 (reporter)
2011-11-24 02:09

I did find FOrgWndProc := Pointer(SetWindowLongPtr(FHandle, GWL_WNDPROC, LONG_PTR(FInstance))) in the new JVCL source but not the old. I then reinstalled the JVCL, and the problem immediately disappeared. Perhaps forgetting to check the "Build Packages" option during the first install caused the component to not actually be updated? Not sure...I'm 100% new to JCL and JVCL. Anyway, thank you for your help in resolving this 64-bit issue; the crash is gone.

Once issue 5716 described at http://issuetracker.delphi-jedi.org/view.php?id=5716 [^] is resolved, I think this component will be very useful.

- Issue History
Date Modified Username Field Change
2011-11-21 21:02 eje92 New Issue
2011-11-21 21:02 eje92 File Added: TJvIPAddressDemo.ZIP
2011-11-22 20:09 AHUser Note Added: 0019121
2011-11-22 20:09 AHUser Assigned To => AHUser
2011-11-22 20:09 AHUser Status new => feedback
2011-11-24 02:09 eje91 Note Added: 0019128
2011-11-24 18:02 AHUser Status feedback => resolved
2011-11-24 18:02 AHUser Fixed in Version => Daily / SVN
2011-11-24 18:02 AHUser Resolution open => fixed
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker